hdu 1081 To The Max ( 最大子矩阵 )

To The Max

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 6612 Accepted Submission(s): 3159


Problem Description
Given a two-dimensional array of positive and negative integers, a sub-rectangle is any contiguous sub-array of size 1 x 1 or greater located within the whole array. The sum of a rectangle is the sum of all the elements in that rectangle. In this problem the sub-rectangle with the largest sum is referred to as the maximal sub-rectangle.

As an example, the maximal sub-rectangle of the array:

0 -2 -7 0
9 2 -6 2
-4 1 -4 1
-1 8 0 -2

is in the lower left corner:

9 2
-4 1
-1 8

and has a sum of 15.

Input
The input consists of an N x N array of integers. The input begins with a single positive integer N on a line by itself, indicating the size of the square two-dimensional array. This is followed by N 2 integers separated by whitespace (spaces and newlines). These are the N 2 integers of the array, presented in row-major order. That is, all numbers in the first row, left to right, then all numbers in the second row, left to right, etc. N may be as large as 100. The numbers in the array will be in the range [-127,127].

Output
Output the sum of the maximal sub-rectangle.

Sample Input
  
  
4 0 -2 -7 0 9 2 -6 2 -4 1 -4 1 -1 8 0 -2

Sample Output
  
  
15

Source

题意:
求矩阵里面的>=1*1规模的子矩阵的最大sum和。sum为子矩阵中各元素的和。

分析:
这题相当于是求二维的最大子串和,想想当初做hdu 1003 max sum一维的时候,就是看当前sum+第i个数,
如果sum<0,则sum=0并以第i+1个数为第一个数继续累加。每次为负就重复这个过程。

现在想想,其实就是一个状态转移的公式:
f[i]=max(0,f[i-1])+a[i]

至于这题,开始找最优子结构的是时候处理错了,开始想的是先找4个为第一层最小结构,然后再接着扩展。
但是这样很容易漏掉一些情况,且对数据处理也很麻烦,甚至到最后自己都搞晕了。

正确的思路是:
先把矩阵预处理。使得map[i][j]存的是第i行前j个数的和
例如:样例中矩阵
           0 -2  -7 0
           9  2  -6 2
           -4 1 -4  1
          -1  8  0  -2
处理后变成:
            0 -2 -9 -9
            9 11 5  7 
            -4 -3 -7 -6
             -1  7  7  5
三重for循环,sum+=map[k][j]-map[k][i-1]。 ( map[k][j]-map[k][i-1]表示第k行i列和j列之间的元素和)
注意k为最内层循环,每次都是确定两列后,将行边累加,边找maxsum。
列数的确定也要按一定的顺序,首先i固定在1,j从i到n。然后依次增大i...其实就是外面的两重循环。

这样就能找到遍历所有的子矩阵,找到最大的sum.

注意:max不能初始化为0,因为最大sum可能为负。

代码:
#include<cstdio>
#include<iostream>
#include<algorithm>
#include<cstring>
#define INF  0x3f3f3f3f
using namespace std;

int map[101][101];

int main()
{
    int tmp,i,j,k,n;
    while(scanf("%d",&n)!=EOF)
    {
        memset(map,0,sizeof(map));
        for(i=1;i<=n;i++)
        {
            for(j=1;j<=n;j++)
            {
                scanf("%d",&tmp);
                map[i][j]=map[i][j-1]+tmp;
            }
        }
        int maxsum=-INF,sum;
        for(i=1;i<=n;i++)
        {
            for(j=i;j<=n;j++)
            {
                sum=0;
                for(k=1;k<=n;k++)
                {
                    sum+=map[k][j]-map[k][i-1];
                    //printf("yes:  %d\n",map[k][j]-map[k][i-1]);
                    //printf("test: %d\n",sum);
                    if(sum<0)
                        sum=0;
                    if(sum>maxsum)
                        maxsum=sum;
                    //printf("test: %d %d\n",sum,maxsum);
                }
            }
        }
        printf("%d\n",maxsum);
    }
    return 0;
}





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值