HDU 5971 Wrestling Match(二分图着色)

Wrestling Match

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1833    Accepted Submission(s): 663


Problem Description
Nowadays, at least one wrestling match is held every year in our country. There are a lot of people in the game is "good player”, the rest is "bad player”. Now, Xiao Ming is referee of the wrestling match and he has a list of the matches in his hand. At the same time, he knows some people are good players,some are bad players. He believes that every game is a battle between the good and the bad player. Now he wants to know whether all the people can be divided into "good player" and "bad player".
 

Input
Input contains multiple sets of data.For each set of data,there are four numbers in the first line:N (1 ≤ N≤ 1000)、M(1 ≤M ≤ 10000)、X,Y(X+Y≤N ),in order to show the number of players(numbered 1toN ),the number of matches,the number of known "good players" and the number of known "bad players".In the next M lines,Each line has two numbersa, b(a≠b) ,said there is a game between a and b .The next line has X different numbers.Each number is known as a "good player" number.The last line contains Y different numbers.Each number represents a known "bad player" number.Data guarantees there will not be a player number is a good player and also a bad player.
 

Output
If all the people can be divided into "good players" and "bad players”, output "YES", otherwise output "NO".
 

Sample Input
  
  
5 4 0 0 1 3 1 4 3 5 4 5 5 4 1 0 1 3 1 4 3 5 4 5 2
 

Sample Output
  
  
NO YES
 

Source
 

题意:
给你m场比赛,每场比赛分别是good选手和bad选手之间的。在给你x已经确定的good选手,y已经确定的bad选手。
让你判断能不能给每个选手分good和bad,有不能确定的就输出no。
POINT:
我觉得题意有点不明确,做法就是先跑已经确定的选手DFS,2分图染色一下。
再跑比赛的。
剩下来没有染色的,或者在染色过程中存在矛盾,就输出NO。

#include <iostream>
#include <stdio.h>
#include <math.h>
#include <string.h>
#include <vector>
using namespace std;
const int maxn = 1000+44;
vector<int>G[maxn];
int flag[maxn];
int n,ans;
void init()
{
    for(int i=1; i<=n; i++)
    {
        G[i].clear();
    }
    memset(flag,0,sizeof flag);
    ans=1;
}
void dfs(int u,int pre,int k)
{
    if(!ans) return;
    flag[u]=k;
    for(int i=0; i<G[u].size(); i++)
    {
        int v=G[u][i];
        if(v==pre) continue;
        if(k==1)
        {
            if(flag[v]==1)
            {
                ans=0;
                return ;
            }
            if(flag[v]==0)
            dfs(v,u,-1);
        }
        else
        {
            if(flag[v]==-1)
            {
                ans=0;
                return;
            }
            if(flag[v]==0)
            dfs(v,u,1);
        }
    }
}
int main()
{
    int x,y,m;
    while(~scanf("%d %d %d %d",&n,&m,&x,&y))
    {
        init();
        for(int i=1; i<=m; i++)
        {
            int u,v;
            scanf("%d %d",&u,&v);
            G[u].push_back(v);
            G[v].push_back(u);
        }
        for(int i=1; i<=x; i++)
        {
            int u;
            scanf("%d",&u);
            flag[u]=1;
        }
        for(int i=1; i<=y; i++)
        {
            int u;
            scanf("%d",&u);
            flag[u]=-1;
        }
        for(int i=1; i<=n; i++)
        {
            if(flag[i]!=0)
            {
                dfs(i,0,flag[i]);
            }
        }
        for(int i=1;i<=n;i++){
            if(flag[i]==0&&G[i].size()!=0)
            {
                dfs(i,0,1);
            }
        }
        for(int i=1;i<=n;i++){
            if(flag[i]==0){
                ans=0;
                break;
            }
        }
        if(ans){
            printf("YES\n");
        }
        else printf("NO\n");

    }

    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值