HDU 5718 Oracle(大数)

7 篇文章 0 订阅

Oracle

Time Limit: 8000/4000 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)
Total Submission(s): 1235    Accepted Submission(s): 535


Problem Description
There is once a king and queen, rulers of an unnamed city, who have three daughters of conspicuous beauty.

The youngest and most beautiful is Psyche, whose admirers, neglecting the proper worship of the love goddess Venus, instead pray and make offerings to her. Her father, the king, is desperate to know about her destiny, so he comes to the Delphi Temple to ask for an oracle.

The oracle is an integer  n  without leading zeroes. 

To get the meaning, he needs to rearrange the digits and split the number into <b>two positive integers without leading zeroes</b>, and their sum should be as large as possible. 

Help him to work out the maximum sum. It might be impossible to do that. If so, print `Uncertain`.
 

Input
The first line of the input contains an integer  T   (1T10) , which denotes the number of test cases.

For each test case, the single line contains an integer  n   (1n<1010000000) .
 

Output
For each test case, print a positive integer or a string `Uncertain`.
 

Sample Input
  
  
3 112 233 1
 

Sample Output
  
  
22 35 Uncertain
Hint
In the first example, it is optimal to split $ 112 $ into $ 21 $ and $ 1 $, and their sum is $ 21 + 1 = 22 $. In the second example, it is optimal to split $ 233 $ into $ 2 $ and $ 33 $, and their sum is $ 2 + 33 = 35 $. In the third example, it is impossible to split single digit $ 1 $ into two parts.
 

Source
 


题意:
给你一串数,让你任意组合这些数,变成两个【正数】,求相加和最大。
不能变成则输出“”

POINT:
只要这串数有2个以上非0的数,就可以拆。

拆肯定是拿一个最小的非0的数。加上一个9998877……00排列的数。
模拟大数加一下就好

#include <stdio.h>
#include <map>
#include<iostream>
#include <math.h>
#include <algorithm>
#include <string.h>
#include <vector>
#include <queue>
#include <set>
using namespace std;
typedef long long  LL;
const int maxn = 10001000;
char s[maxn];
int num[20];
int a[maxn];
int main()
{
    int T;
    scanf("%d",&T);
    while(T--){
        memset(num,0,sizeof num);
        scanf("%s",s);
        int l=strlen(s);
        for(int i=0;i<l;i++){
            num[s[i]-'0']++;

        }
        if(num[0]>=l-1){
            printf("Uncertain\n");
            continue;
        }
        int k;
        for(int i=1;i<=9;i++){
            if(num[i]>=1){
                k=i;
                num[i]--;
                break;
            }
        }
        for(int i=0;i<=l;i++) a[i]=0;
        int now=0;
        for(int i=0;i<=9;i++){
            for(int j=1;j<=num[i];j++){
                a[++now]=i;
            }
        }
        a[1]+=k;
        for(int i=1;i<=now;i++){
            if(a[i]>=10){
                a[i+1]+=a[i]/10;
                a[i]%=10;
                if(i==now){
                    now++;
                    break;
                }
            }else{
                break;
            }
        }
        for(int i=now;i>=1;i--){
            printf("%d",a[i]);
        }
        printf("\n");
    }


    return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值