HDU 5718 Oracle

Problem Description
There is once a king and queen, rulers of an unnamed city, who have three daughters of conspicuous beauty.

The youngest and most beautiful is Psyche, whose admirers, neglecting the proper worship of the love goddess Venus, instead pray and make offerings to her. Her father, the king, is desperate to know about her destiny, so he comes to the Delphi Temple to ask for an oracle.

The oracle is an integer  n  without leading zeroes. 

To get the meaning, he needs to rearrange the digits and split the number into <b>two positive integers without leading zeroes</b>, and their sum should be as large as possible. 

Help him to work out the maximum sum. It might be impossible to do that. If so, print `Uncertain`.
 

Input
The first line of the input contains an integer  T   (1T10) , which denotes the number of test cases.

For each test case, the single line contains an integer  n   (1n<1010000000) .
 

Output
For each test case, print a positive integer or a string `Uncertain`.
 

Sample Input
  
  
3 112 233 1
 

Sample Output
  
  
22 35 Uncertain
Hint
In the first example, it is optimal to split $ 112 $ into $ 21 $ and $ 1 $, and their sum is $ 21 + 1 = 22 $. In the second example, it is optimal to split $ 233 $ into $ 2 $ and $ 33 $, and their sum is $ 2 + 33 = 35 $. In the third example, it is impossible to split single digit $ 1 $ into two parts.

简单题,先判断是否有两个非零数,然后就是取一个最小的出来加进去

#include<set>
#include<map>
#include<stack>
#include<queue>
#include<bitset>
#include<cstdio>
#include<string>
#include<cstring>
#include<iostream>
#include<algorithm>
#include<functional>
#define rep(i,j,k) for (int i = j; i <= k; i++)
#define per(i,j,k) for (int i = j; i >= k; i--)
using namespace std;
const int low(int x) { return x&-x; }
const int N = 1e7 + 10;
const int INF = 0x7FFFFFFF;
int T, n, m, f[10], a[N];
char s;

int main()
{
    scanf("%d", &T);    getchar();
    while (T--)
    {
        //scanf("%d%d", &n, &m);
        memset(f, 0, sizeof(f));
        while ((s = getchar()) <= '9' && s >= '0') f[s - '0']++;
        int sum = 0;
        rep(i, 1, 9) sum += f[i];
        if (sum < 2) printf("Uncertain\n");
        else
        {
            int t = 0, k = 0;
            rep(i, 1, 9) if (f[i]) { f[i]--; k = i; break; }
            rep(i, 0, 9) while (f[i]--) a[t++] = i;
            rep(i, 0, t - 1)
            {
                int kk = a[i];
                a[i] = (a[i] + k) % 10;
                k = (k + kk) / 10;
            }
            if (k) a[t++] = k;
            while (t--) printf("%d", a[t]);
            putchar(10);
        }
    }
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值