HDU 4403 A very hard Aoshu problem (DFS+状压)

21 篇文章 0 订阅
11 篇文章 0 订阅

A very hard Aoshu problem

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1743    Accepted Submission(s): 1200


Problem Description
Aoshu is very popular among primary school students. It is mathematics, but much harder than ordinary mathematics for primary school students. Teacher Liu is an Aoshu teacher. He just comes out with a problem to test his students:

Given a serial of digits, you must put a '=' and none or some '+' between these digits and make an equation. Please find out how many equations you can get. For example, if the digits serial is "1212", you can get 2 equations, they are "12=12" and "1+2=1+2". Please note that the digits only include 1 to 9, and every '+' must have a digit on its left side and right side. For example, "+12=12", and "1++1=2" are illegal. Please note that "1+11=12" and "11+1=12" are different equations.
 

Input
There are several test cases. Each test case is a digit serial in a line. The length of a serial is at least 2 and no more than 15. The input ends with a line of "END".
 

Output
For each test case , output a integer in a line, indicating the number of equations you can get.
 

Sample Input
  
  
1212 12345666 1235 END
 

Sample Output
  
  
2 2 0
 

Source
 



题意:

加一个等号,和任意加号,使等式成立。


POINT:

长度很小,直接暴力,可以状态压缩DFS,写起来会很清楚。



#include <stdio.h>
#include <map>
#include<iostream>
#include <math.h>
#include <algorithm>
#include <string.h>
#include <vector>
#include <queue>
#include <set>
using namespace std;
typedef long long  LL;
const int maxn = 22;
int a[maxn];
int l;
int ans=0;
void haha(int t1,int t2,int deng)
{
    int aa=0,bb=0;
    int temp=a[1];
    for(int i=2;i<=deng;i++){
        if(t1&(1<<(i-2))){
            aa+=temp;
            temp=a[i];
        }else{
            temp=temp*10;
            temp+=a[i];
        }
    }
    aa+=temp;
    temp=a[deng+1];
    for(int i=deng+2;i<=l;i++){
        if(t2&(1<<(i-deng-2))){
            bb+=temp;
            temp=a[i];
        }else{
            temp=temp*10;
            temp+=a[i];
        }
    }
    bb+=temp;
    if(aa==bb) ans++;

}
int main()
{
    char s[22];
    while(~scanf("%s",s)){
        if(!strcmp(s, "END")){
            break;
        }else{
            ans=0;
            l=strlen(s);
            for(int i=0;i<l;i++){
                a[i+1]=s[i]-'0';
            }
            for(int i=1;i<l;i++){
                int t1=1<<(i-1);
                int t2=1<<(l-i-1);
                for(int z=0;z<t1;z++){
                    for(int x=0;x<t2;x++){
                        haha(z,x,i);
                    }
                }
            }
            printf("%d\n",ans);
        }
    }


    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值