HDU 5816 Hearthstone(状态压缩DP+概率)

21 篇文章 0 订阅
1 篇文章 0 订阅

Hearthstone

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1119    Accepted Submission(s): 554


Problem Description
Hearthstone is an online collectible card game from Blizzard Entertainment. Strategies and luck are the most important factors in this game. When you suffer a desperate situation and your only hope depends on the top of the card deck, and you draw the only card to solve this dilemma. We call this "Shen Chou Gou" in Chinese.

Now you are asked to calculate the probability to become a "Shen Chou Gou" to kill your enemy in this turn. To simplify this problem, we assume that there are only two kinds of cards, and you don't need to consider the cost of the cards.
  -A-Card: If the card deck contains less than two cards, draw all the cards from the card deck; otherwise, draw two cards from the top of the card deck.
  -B-Card: Deal X damage to your enemy.

Note that different B-Cards may have different X values.
At the beginning, you have no cards in your hands. Your enemy has P Hit Points (HP). The card deck has N A-Cards and M B-Cards. The card deck has been shuffled randomly. At the beginning of your turn, you draw a card from the top of the card deck. You can use all the cards in your hands until you run out of it. Your task is to calculate the probability that you can win in this turn, i.e., can deal at least P damage to your enemy.

 

Input
The first line is the number of test cases T (T<=10). 
Then come three positive integers P (P<=1000), N and M (N+M<=20), representing the enemy’s HP, the number of A-Cards and the number of B-Cards in the card deck, respectively. Next line come M integers representing X (0<X<=1000) values for the B-Cards.
 

Output
For each test case, output the probability as a reduced fraction (i.e., the greatest common divisor of the numerator and denominator is 1). If the answer is zero (one), you should output 0/1 (1/1) instead.
 

Sample Input
  
  
2 3 1 2 1 2 3 5 10 1 1 1 1 1 1 1 1 1 1
 

Sample Output
  
  
1/3 46/273
 

Author
SYSU
 

Source
 


题意:

给你N张奥数智慧,M张火球术(不打6) 打几下面给出。求出摸1张牌打出>=P伤害的概率。


POINT:

遍历各种摸牌可能。DP[i]代表当前i状态的数量。详细解释在代码里。


#include <iostream>
#include <string.h>
#include <stdio.h>
#include <stack>
#include <algorithm>
#include <math.h>
using namespace std;
#define ll long long
ll f[26],dp[1<<20];
int P,N,M;
int atk[20];
void init()
{
    f[1]=1;
    f[0]=1;
    for(int i=2;i<=20;i++) f[i]=f[i-1]*i;
}
int check(int now)
{
    int sum=0;
    now=now>>N;
    for(int i=0;i<M;i++)
    {
        if(now&(1<<i))
        {
            sum+=atk[i];
        }
    }
    if(sum>=P) return 1;
    return 0;
}
ll gcd(ll a,ll b)
{
    return a==0?b:gcd(b%a,a);
}
int main()
{
    init();
    int T;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d %d %d",&P,&N,&M);
        memset(dp,0,sizeof dp);
        for(int i=0;i<(N+M);i++) dp[1<<i]=1;
        for(int i=0;i<M;i++)
        {
            scanf("%d",&atk[i]);
        }
        int amark=(1<<N)-1;
        int tot=(1<<(N+M))-1;
        ll ans=0;
        for(int i=0;i<=tot;i++)
        {
            int have = __builtin_popcount(i);
            int left = N+M-have;
            int havea= __builtin_popcount(i&amark);
            if(check(i))
            {
                ans+=dp[i]*f[left];//当前的状态的数量*之后的全排序。
                continue;
            }
            if(havea*2+1-have<=0) continue;//无牌可摸
            for(int j=0;j<N+M;j++)
            {
                if(!((i>>j)&1))
                {
                    dp[i|(1<<j)]+=dp[i];//摸一张牌,加上之前的数量。
                }
            }
        }
        ll d=gcd(ans,f[N+M]);
        printf("%lld/%lld\n",ans/d,f[N+M]/d);
    }
    
}



  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值