L2-006. 树的遍历

L2-006. 树的遍历

时间限制
400 ms
内存限制
65536 kB
代码长度限制
8000 B
判题程序
Standard
作者
陈越

给定一棵二叉树的后序遍历和中序遍历,请你输出其层序遍历的序列。这里假设键值都是互不相等的正整数。

输入格式:

输入第一行给出一个正整数N(<=30),是二叉树中结点的个数。第二行给出其后序遍历序列。第三行给出其中序遍历序列。数字间以空格分隔。

输出格式:

在一行中输出该树的层序遍历的序列。数字间以1个空格分隔,行首尾不得有多余空格。

输入样例:
7
2 3 1 5 7 6 4
1 2 3 4 5 6 7
输出样例:
4 1 6 3 5 7 2

后序遍历得知根的键值,用这个键值去中序遍历里找。即找到左右子树。


#include <iostream>
#include <stdio.h>
#include <math.h>
#include <string.h>
#include <algorithm>
#include <queue>
#include <vector>
using namespace std;
#define LL long long
#define lt x<<1
#define rt x<<1|1
const int maxn = 50+111;
const int inf = 0x3f3f3f3f;
int a[maxn],b[maxn];
int cnt=0;
struct node
{
	int l,r,val;
}tree[maxn];
int build(int la,int ra,int lb,int rb)
{
	if(la>ra) return 0;
	int val=a[ra];
	int i;
	for(i=lb;i<=rb;i++){
		if(b[i]==val) break;
	}

	tree[++cnt].val=val;
	int root=cnt;
	tree[root].l=build(la,ra-rb+i-1,lb,i-1);
	tree[root].r=build(ra-rb+i,ra-1,i+1,rb);
	return root;
}
int main()
{
	int n;
	scanf("%d",&n);
	for(int i=1;i<=n;i++) scanf("%d",&a[i]);
	for(int i=1;i<=n;i++) scanf("%d",&b[i]);
	int root=build(1,n,1,n);
	queue<int>q;
	q.push(root);
	cnt=0;
	while(!q.empty()){
		cnt++;
		int a = q.front();
		q.pop();
		printf("%d",tree[a].val);
		if(tree[a].l!=0)
			q.push(tree[a].l);
		if(tree[a].r!=0)
		q.push(tree[a].r);
		if(cnt!=n) printf(" "); else printf("\n");
	}

	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值