L2-013. 红色警报
时间限制
400 ms
内存限制
65536 kB
代码长度限制
8000 B
判题程序
Standard
作者
陈越
战争中保持各个城市间的连通性非常重要。本题要求你编写一个报警程序,当失去一个城市导致国家被分裂为多个无法连通的区域时,就发出红色警报。注意:若该国本来就不完全连通,是分裂的k个区域,而失去一个城市并不改变其他城市之间的连通性,则不要发出警报。
输入格式:
输入在第一行给出两个整数N(0 < N <=500)和M(<=5000),分别为城市个数(于是默认城市从0到N-1编号)和连接两城市的通路条数。随后M行,每行给出一条通路所连接的两个城市的编号,其间以1个空格分隔。在城市信息之后给出被攻占的信息,即一个正整数K和随后的K个被攻占的城市的编号。
注意:输入保证给出的被攻占的城市编号都是合法的且无重复,但并不保证给出的通路没有重复。
输出格式:
对每个被攻占的城市,如果它会改变整个国家的连通性,则输出“Red Alert: City k is lost!”,其中k是该城市的编号;否则只输出“City k is lost.”即可。如果该国失去了最后一个城市,则增加一行输出“Game Over.”。
输入样例:5 4 0 1 1 3 3 0 0 4 5 1 2 0 4 3输出样例:
City 1 is lost. City 2 is lost. Red Alert: City 0 is lost! City 4 is lost. City 3 is lost. Game Over.
反复并查集。
#include <iostream>
#include <stdio.h>
#include <math.h>
#include <string.h>
#include <algorithm>
#include <queue>
using namespace std;
#define LL long long
#define lt x<<1
#define rt x<<1|1
const int maxn = 1e3+111;
const int inf = 0x3f3f3f3f;
int fa[maxn];
int findi(int x)
{
return fa[x]==x?x:fa[x]=findi(fa[x]);
}
struct node
{
int x,y;
}len[5020];
int flag[maxn];
int now=0;
int n,m;
int f()
{
for(int i=0;i<=n;i++) fa[i]=i;
int num = n-now;
for(int i=1;i<=m;i++){
if(flag[len[i].x]==1||flag[len[i].y]==1) continue;
int x = findi(len[i].x);
int y = findi(len[i].y);
if(x!=y){
fa[y]=x;
num--;
}
}
return num;
}
int main()
{
scanf("%d %d",&n,&m);
for(int i=1;i<=m;i++){
scanf("%d %d",&len[i].x,&len[i].y);
}
int k;scanf("%d",&k);
int pre=f();
while(k--){
now++;
int hao;scanf("%d",&hao);
flag[hao]=1;
int num=f();
if(num>pre){
printf("Red Alert: City %d is lost!\n",hao);
}else{
printf("City %d is lost.\n",hao);
}
pre=num;
if(num==0){
printf("Game Over.\n");
}
}
return 0;
}