L2-016. 愿天下有情人都是失散多年的兄妹

L2-016. 愿天下有情人都是失散多年的兄妹

时间限制
200 ms
内存限制
65536 kB
代码长度限制
8000 B
判题程序
Standard
作者
陈越

呵呵。大家都知道五服以内不得通婚,即两个人最近的共同祖先如果在五代以内(即本人、父母、祖父母、曾祖父母、高祖父母)则不可通婚。本题就请你帮助一对有情人判断一下,他们究竟是否可以成婚?

输入格式:

输入第一行给出一个正整数N(2 <= N <= 104),随后N行,每行按以下格式给出一个人的信息:

本人ID 性别 父亲ID 母亲ID

其中ID是5位数字,每人不同;性别M代表男性、F代表女性。如果某人的父亲或母亲已经不可考,则相应的ID位置上标记为-1。

接下来给出一个正整数K,随后K行,每行给出一对有情人的ID,其间以空格分隔。

注意:题目保证两个人是同辈,每人只有一个性别,并且血缘关系网中没有乱伦或隔辈成婚的情况。

输出格式:

对每一对有情人,判断他们的关系是否可以通婚:如果两人是同性,输出“Never Mind”;如果是异性并且关系出了五服,输出“Yes”;如果异性关系未出五服,输出“No”。

输入样例:
24
00001 M 01111 -1
00002 F 02222 03333
00003 M 02222 03333
00004 F 04444 03333
00005 M 04444 05555
00006 F 04444 05555
00007 F 06666 07777
00008 M 06666 07777
00009 M 00001 00002
00010 M 00003 00006
00011 F 00005 00007
00012 F 00008 08888
00013 F 00009 00011
00014 M 00010 09999
00015 M 00010 09999
00016 M 10000 00012
00017 F -1 00012
00018 F 11000 00013
00019 F 11100 00018
00020 F 00015 11110
00021 M 11100 00020
00022 M 00016 -1
00023 M 10012 00017
00024 M 00022 10013
9
00021 00024
00019 00024
00011 00012
00022 00018
00001 00004
00013 00016
00017 00015
00019 00021
00010 00011
输出样例:
Never Mind
Yes
Never Mind
No
Yes
No
Yes
No
No

提交代码


版权所有 (C) 2011-2018 浙江大学计算机科学与技术学院


#include <iostream>
#include <stdio.h>
#include <math.h>
#include <string.h>
#include <algorithm>
#include <set>
using namespace std;
#define LL long long
#define lt x<<1
#define rt x<<1|1
const int maxn = 4e5+111;
const int inf = 0x3f3f3f3f;
int head[maxn],nxt[maxn];
int to[maxn];
int cnt=0;
int x[maxn];
int temp=0;
set<int> st;
void dfs(int now,int w)
{
	if(w==4) return;
	for(int i=head[now];~i;i=nxt[i]){
		int v=to[i];
		temp++;
		dfs(v,w+1);
		st.insert(v);
	}
}
int f(int x)
{
	temp=0;
	dfs(x,0);
	return temp;
}
int main()
{
	int n;
	scanf("%d",&n);
	memset(head,-1,sizeof head);
	char sex;
	for(int i=1;i<=n;i++){
		int ben;scanf("%d",&ben);
		cin>>sex;
		if(sex=='M') x[ben]=1;
		else x[ben]=0;
		int fa,ma;scanf("%d %d",&fa,&ma);
		if(fa!=-1){
			nxt[++cnt]=head[ben];
			head[ben]=cnt;
			to[cnt]=fa;
			x[fa]=1;
		}
		if(ma!=-1){
			nxt[++cnt]=head[ben];
			head[ben]=cnt;
			to[cnt]=ma;
			x[ma]=0;
		}
	}
	int q;scanf("%d",&q);
	while(q--){
		st.clear();
		int p1,p2;
		scanf("%d %d",&p1,&p2);
		if(x[p1]+x[p2]==1){
			int num=f(p1);
			num+=f(p2);
			if(num>st.size()){
				printf("No\n");
			}else{
				printf("Yes\n");
			}
		}else{
			printf("Never Mind\n");
		}
	}

	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值