HDU 2476 - String painter(区间DP)

9 篇文章 0 订阅

String painter

Time Limit: 5000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 5503    Accepted Submission(s): 2613


Problem Description
There are two strings A and B with equal length. Both strings are made up of lower case letters. Now you have a powerful string painter. With the help of the painter, you can change a segment of characters of a string to any other character you want. That is, after using the painter, the segment is made up of only one kind of character. Now your task is to change A to B using string painter. What’s the minimum number of operations?
 

Input
Input contains multiple cases. Each case consists of two lines:
The first line contains string A.
The second line contains string B.
The length of both strings will not be greater than 100.
 

Output
A single line contains one integer representing the answer.
 

Sample Input
 
 
zzzzzfzzzzz abcdefedcba abababababab cdcdcdcdcdcd
 

Sample Output
 
 
6 7
 

Source
 

Recommend
lcy
 

这题我认为是最难理解的。

题解


#include <iostream>
#include <math.h>
#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;
#define LL long long
const int inf = 0x3f3f3f3f;

int dp[111][111];
int ans[111];
int main()
{
	char s1[111],s2[111];
	while (~scanf("%s%s",s1+1,s2+1)) {
		s1[0]=1;
		memset(dp,0,sizeof dp);
		int n=strlen(s1)-1;
		for(int i=1;i<=n;i++){
			dp[i][i]=1;
		}
		for(int len = 2;len<=n;len++){
			for(int i = 1;i<=n-len+1;i++){
				int to = i+len-1;
				dp[i][to]=1+dp[i+1][to];//涂i
				for(int k=i+1;k<=to;k++){//去搜索,能不能不涂i
					if(s2[k]==s2[i])
						dp[i][to]=min(dp[i][to],dp[i+1][k]+dp[k+1][to]);
				}
			}
		}
		ans[0]=0;
		for(int i=1;i<=n;i++){
			ans[i]=inf;
			if(s1[i]==s2[i]) ans[i]=ans[i-1];
			else{
				for(int j=0;j<i;j++){
					ans[i]=min(ans[i],ans[j]+dp[j+1][i]);
				}
			}
		}
		printf("%d\n",ans[n]);
	}
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值