HDU2476-String painter

String painter

                                                                           Time Limit: 5000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
                                                                                                      Total Submission(s): 3553    Accepted Submission(s): 1649

Problem Description
There are two strings A and B with equal length. Both strings are made up of lower case letters. Now you have a powerful string painter. With the help of the painter, you can change a segment of characters of a string to any other character you want. That is, after using the painter, the segment is made up of only one kind of character. Now your task is to change A to B using string painter. What’s the minimum number of operations?
 
Input
Input contains multiple cases. Each case consists of two lines:
The first line contains string A.
The second line contains string B.
The length of both strings will not be greater than 100.
 
Output
A single line contains one integer representing the answer.
 
Sample Input
  
  
zzzzzfzzzzz abcdefedcba abababababab cdcdcdcdcdcd
 
Sample Output
  
  
6 7
 
Source

题意:给出两个串s1和s2,一次只能将一个区间刷一次,问最少几次能让s1=s2

解题思路:先 用区间DP 算由空白串直接变成str2, 然后再计算从str1变成str2

#include <iostream>
#include <string.h>
#include <algorithm>
#include <stdio.h>

using namespace std;

const int MAXN=110;
int dp[MAXN][MAXN];
char str1[MAXN],str2[MAXN];
int ans[MAXN];

int main()
{
    while(~scanf("%s%s",str1,str2))
    {
        int len=strlen(str1);
        memset(dp,0,sizeof(dp));
        for(int j=0;j<len;j++)
        {
            for(int i=j;i>=0;i--)
            {
                dp[i][j]=dp[i+1][j]+1;
                for(int k=i+1;k<=j;k++)
                    if(str2[i]==str2[k])
                        dp[i][j]=min(dp[i][j],dp[i+1][k]+dp[k+1][j]);
            }
        }
        for(int i=0;i<len;i++)
        {
            ans[i]=dp[0][i];
            if(str1[i]==str2[i])
            {
                if(i==0) ans[i]=0;
                else ans[i]=ans[i-1];
            }
            for(int j=0;j<i;j++)
                ans[i]=min(ans[i],ans[j]+dp[j+1][i]);
        }
        printf("%d\n",ans[len-1]);
    }
    return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值