NYOJ 216题 A problem is easy

A problem is easy

时间限制: 1000 ms  |  内存限制: 65535 KB
难度: 3
描述
When Teddy was a child , he was always thinking about some simple math problems ,such as “What it’s 1 cup of water plus 1 pile of dough ..” , “100 yuan buy 100 pig” .etc..

One day Teddy met a old man in his dream , in that dream the man whose name was“RuLai” gave Teddy a problem :

Given an N , can you calculate how many ways to write N as i * j + i + j (0 < i <= j) ?

Teddy found the answer when N was less than 10…but if N get bigger , he found it was too difficult for him to solve.
Well , you clever ACMers ,could you help little Teddy to solve this problem and let him have a good dream ?
输入
The first line contain a T(T <= 2000) . followed by T lines ,each line contain an integer N (0<=N <= 10^11).
输出
For each case, output the number of ways in one line
样例输入
 
  
2
1
3
样例输出
 
  
0
1
上传者

苗栋栋


emmm 数学题  

因为 i*j+i+j= n  

式子可变化为  i*j+i+j +1= n +1  ——> (i+1)*(j+1)= n

且 0<i <= j

所以此题类似于求素数,即 转化为从2 到 sqrt(n+1)闭区间内存在多少个n+1的因子。


注意:

        1.此题的n和循环变量i要开到long 或者 long long

        2.不要将sqrt放入循环体的判断语句中,亲身试验,会超时。(不排除其他客观原因)


代码如下:

#include<stdio.h>
#include<math.h>
int main(){
	int t;
	long n,i;
	scanf("%d",&t);
	while(t--){
		int ans = 0;
		scanf("%ld",&n);
		int m = sqrt(n+1);
		for( i = 2; i <= m; i++){
			if((n+1)%i == 0) ans++;
		}
		printf("%d\n",ans);
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值