(LightOJ - 1136 )Division by 3

There is sequence 1, 12, 123, 1234, ..., 12345678910, ... . Now you are given two integers A and B, you have to find the number of integers from Ath number to Bth (inclusive) number, which are divisible by 3.

For example, let A = 3. B = 5. So, the numbers in the sequence are, 123, 1234, 12345. And 123, 12345 are divisible by 3. So, the result is 2.

Input

Input starts with an integer T (≤ 10000), denoting the number of test cases.

Each case contains two integers A and B (1 ≤ A ≤ B < 231) in a line.

Output

For each case, print the case number and the total numbers in the sequence between Ath and Bth which are divisible by3.

Sample Input

2

3 5

10 110

Sample Output

Case 1: 2

Case 2: 67


找规律:  1 12 123 1234 12345 123456  ......

             其中12 123 12345 123456 可以被3 整除

         可以看出每三个数有2个能被3整除



代码:

   

#include <iostream>
#include <cstdio>
int main()
{  
    int t , w;
    scanf("%d",&t);
    w = 1;
    while(t--)
    {
    	 int a , b;
    	 scanf("%d %d",&a,&b);
    	 int ans1 = b / 3 * 2;;   //  1 12 123 每三个数有两个能被3整除 , 此处判断b前面(包括b)有几个3的倍数,乘以2 
    	 if(b % 3 == 2)
    	 {
    	 	  ans1++;          //如果b处于能被3整除的前一位  比如 1 12 123 1234 12345 
		 }
		 int ans2 = a / 3 * 2;        
		 if( a % 3 == 0)       
		 {
		 	 ans2--;                 // 如果a刚好被 3 整除 , 就减 1 ,我们要的是a之前 (不能包括 a) ,能被3整除的数的个数  
		 }
		 int ans = ans1 - ans2;         // 两者相减为结果 
		 printf("Case %d: %d\n",w++ , ans);
	}
	return 0;
}










  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值