*规律-技巧

圆周率用acos(-1.0) 使用longlong
Time Limit:2000MS     Memory Limit:32768KB     64bit IO Format:%lld & %llu

Description

There is sequence 1, 12, 123, 1234, ..., 12345678910, ... . Now you are given two integers A and B, you have to find the number of integers fromAth number to Bth (inclusive) number, which are divisible by 3.

For example, let A = 3. B = 5. So, the numbers in the sequence are, 123, 1234, 12345. And 123, 12345 are divisible by 3. So, the result is 2.

Input

Input starts with an integer T (≤ 10000), denoting the number of test cases.

Each case contains two integers A and B (1 ≤ A ≤ B < 231) in a line.

Output

For each case, print the case number and the total numbers in the sequence between Ath and Bth which are divisible by 3.

Sample Input

2

3 5

10 110

Sample Output

Case 1: 2

Case 2: 67

题意:计算第A个数到第B个数之间有多少个数是3的倍数

题解:判断一个数是否是3的倍数,即判断将各位数加起来之和是否是3的倍数,直接一个一个判断会超时

           那么 如何算出第A个数之前有多少个数是3的倍数?可以找到一个规律:

           序号            数值            各位数和            是否是3的倍数

           1                   1                     1                            0

           2                   12                    3                            1

          3                     123                6                             1

          4                   1234               10                           0

          5                   12345             15                          1

          6                 123456             21                          1

        ........

可以发现,每三个一组,第一个不是3的倍数,后两个是3的倍数,那么就容易计算个数了。。

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
long long f(long long n)
{
	long long s=n/3;
	long long sum;
	if(n%3==1||n%3==0)
	sum=s*2;
	else
	sum=s*2+1;
	return sum;
}
int main()
{
	int t,k=1;
	long long a,b;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%lld%lld",&a,&b);
		long long num=0;
		for(int i=a;i<=b;i++)
		{
			num=f(b)-f(a)+(a%3==1?0:1);//判断a是否是3的倍数
		}
		printf("Case %d: ",k++);
		printf("%lld\n",num);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值