POJ - 3723 Conscription(kruskal+最大权森林)

Conscription

Time Limit: 1000MS
Memory Limit: 65536K
Description
Windy has a country, and he wants to build an army to protect his country. He has picked up N girls and M boys and wants to collect them to be his soldiers. To collect a soldier without any privilege, he must pay 10000 RMB. There are some relationships between girls and boys and Windy can use these relationships to reduce his cost. If girl x and boy y have a relationship d and one of them has been collected, Windy can collect the other one with 10000-d RMB. Now given all the relationships between girls and boys, your assignment is to find the least amount of money Windy has to pay. Notice that only one relationship can be used when collecting one soldier.
Input
The first line of input is the number of test case.
The first line of each test case contains three integers, N, M and R.
Then R lines followed, each contains three integers xi, yi and di.
There is a blank line before each test case.
1 ≤ N, M ≤ 10000
0 ≤ R ≤ 50,000
0 ≤ xi < N
0 ≤ yi < M
0 < di < 10000
Output
For each test case output the answer in a single line.
Sample Input
2

5 5 8
4 3 6831
1 3 4583
0 0 6592
0 1 3063
3 3 4975
1 3 2049
4 2 2104
2 2 781

5 5 10
2 4 9820
3 2 6236
3 1 8864
2 4 8326
2 0 5156
2 0 1463
4 1 2439
0 4 4373
3 4 8889
2 4 3133
Sample Output
71071
54223

刚拿到这道题目一看,嗯,很简单嘛,不就是最大生成树的裸题吗,然而在输出里面却出现了错误 ∑(っ °Д °;)っ
后来仔细想了一下,发现这道题将所有的点都分为了“男”“女”两类,只有男女可能联通,而且联通可能出现圈,所以直接来是不行滴。
为了获取更多的亲密值,我们可以将所有给出的关系中的亲密值加负,同时将每对男女中的男树+n,将之放到女树之后,变成有向图,那么就不存在圈的问题啦╮(╯▽╰)╭ ,之后kruskal一下就好啦!

#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;
#define MAX 100005
int par[MAX];
int rak[MAX];
int n,m,r;
struct edge
{
    int u,v,cost;
};
edge es[MAX];
void init(int n)
{
    for(int i=0;i<=n;i++)
    {
        par[i]=i;
        rak[i]=0;
    }
}
int find(int x)
{
    if(par[x]==x)
        return x;
    else
        return par[x]=find(par[x]);
}
void unite(int x,int y)
{
    x=find(x);
    y=find(y);
    if(x==y)
        return ;
    if(rak[x]<rak[y])
    {
        par[x]=y;
    }
    else
    {
        par[y]=x;
    }
    if(rak[x]==rak[y])
        rak[x]++;
}
bool same(int x,int y)
{
    return find(x)==find(y);
}
bool cmp(const edge&e1,const edge&e2)
{
    return e1.cost<e2.cost;
}
int e;
int kruskal()
{
    sort(es,es+r,cmp);
    init(MAX);
    int res=0;
    for(int i=0;i<r;i++)
    {
        edge e=es[i];
        if(!same(e.u,e.v))
        {
            unite(e.v,e.u);
            res+=e.cost;
            //printf("%d\n",res);
        }
    }
    return res;
}
int x[MAX],y[MAX],d[MAX];
int main()
{
    int zu;
    scanf("%d",&zu);
    while(zu--)
    {
        scanf("%d%d%d",&n,&m,&r);
        for(int i=0;i<r;i++)
        {
            scanf("%d%d%d",&x[i],&y[i],&d[i]);
        }
        int e=n+m;//点数
        for(int i=0;i<r;i++)
        {
            es[i].u=x[i];
            es[i].v=n+y[i];
            es[i].cost=-d[i];
        }

        //printf("%d %d %d",es[i].u,es[i].v,es[i].cost);}
        //printf("%d\n",kruskal());
        printf("%d\n",10000*(n+m)+kruskal());
    }
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值