POJ3723 Conscription 解题报告【Kruskal/最大生成树】

Description
Windy has a country, and he wants to build an army to protect his country. He has picked up N girls and M boys and wants to collect them to be his soldiers. To collect a soldier without any privilege, he must pay 10000 RMB. There are some relationships between girls and boys and Windy can use these relationships to reduce his cost. If girl x and boy y have a relationship d and one of them has been collected, Windy can collect the other one with 10000-d RMB. Now given all the relationships between girls and boys, your assignment is to find the least amount of money Windy has to pay. Notice that only one relationship can be used when collecting one soldier.
Input
The first line of input is the number of test case.
The first line of each test case contains three integers, N, M and R.
Then R lines followed, each contains three integers xi, yi and di.
There is a blank line before each test case.
1 ≤ N, M ≤ 10000
0 ≤ R ≤ 50,000
0 ≤ xi < N
0 ≤ yi < M
0 < di < 10000
Output
For each test case output the answer in a single line.
Sample Input
2
5 5 8
4 3 6831
1 3 4583
0 0 6592
0 1 3063
3 3 4975
1 3 2049
4 2 2104
2 2 781
5 5 10
2 4 9820
3 2 6236
3 1 8864
2 4 8326
2 0 5156
2 0 1463
4 1 2439
0 4 4373
3 4 8889
2 4 3133
Sample Output
71071
54223
解题报告
题意:需要n个男兵和m个女兵,每人入伍要10000元,如果一个女兵/男兵与部队里一个男兵/女兵有关系,那么就可以省d元的入伍费用。
那么很显然,我们把省下来的这d元钱当做边权建单向边,跑一边最大生成树,输出(n+m)*10000-ans就可以了。
此外还要注意,v节点(女兵)的编号要多n。
代码如下:

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int N=10000,R=50000;
struct edge
{
    int u,v,w;
}ed[R+5];
int T,n,m,r,num;
int father[2*N+5];
bool cmp(edge a,edge b){return a.w>b.w;}
int find(int a){return father[a]==a?a:father[a]=find(father[a]);}
int kruskal()
{
    int tot=0,ans=0;
    for(int i=0;i<=n+m;i++)father[i]=i;
    sort(ed+1,ed+1+r,cmp);
    for(int i=1;i<=r;i++)
    {
        int u=ed[i].u,v=ed[i].v;
        u=find(u),v=find(v+n);
        if(u==v)continue;
        father[v]=u;
        ans+=ed[i].w;
        if(++tot==(n+m-1))break;
    }
    return ans;
}
int main()
{
    for(scanf("%d",&T);T;T--)
    {
        scanf("%d%d%d",&n,&m,&r);
        for(int i=1;i<=r;i++)scanf("%d%d%d",&ed[i].u,&ed[i].v,&ed[i].w);
        printf("%d\n",(n+m)*10000-kruskal());
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值