题目1437:To Fill or Not to Fill(贪心算法)

题目描述:

With highways available, driving a car from Hangzhou to any other city is easy. But since the tank capacity of a car is limited, we have to find gas stations on the way from time to time. Different gas station may give different price. You are asked to carefully design the cheapest route to go.

输入:

For each case, the first line contains 4 positive numbers: Cmax (<= 100), the maximum capacity of the tank; D (<=30000), the distance between Hangzhou and the destination city; Davg (<=20), the average distance per unit gas that the car can run; and N (<= 500), the total number of gas stations. Then N lines follow, each contains a pair of non-negative numbers: Pi, the unit gas price, and Di (<=D), the distance between this station and Hangzhou, for i=1,...N. All the numbers in a line are separated by a space.

输出:

For each test case, print the cheapest price in a line, accurate up to 2 decimal places. It is assumed that the tank is empty at the beginning. If it is impossible to reach the destination, print "The maximum travel distance = X" where X is the maximum possible distance the car can run, accurate up to 2 decimal places.

样例输入:
50 1300 12 8
6.00 1250
7.00 600
7.00 150
7.10 0
7.20 200
7.50 400
7.30 1000
6.85 300
50 1300 12 2
7.10 0
7.00 600
样例输出:
749.17
The maximum travel distance = 1200.00

分析:

贪心策略:假设现在自己处于A站,要考虑的是A站要不要加油,加多少油的问题。找到当前可达范围内(距离A站cmax*davg)下一个要加油的站B。

A站可达范围内, 分三种情况:

①没有加油站,------- 快到终点了,则加适量油到终点;或者 Impossible,则A站加满油到哪算哪;

②有更便宜的加油站 ------- 则找到第一家比A便宜的加油站B,加尽可能少的油(也可能油够直接开过去)到B站;

③只有价格更高的加油站,------则当下A站加满油,寻找相对最便宜的加油站B 开过去。

对每一个加油站进行贪心选择。

代码:

#include <iostream>
#include <stdio.h>
#include <algorithm>
#include <math.h>
#include <stdlib.h>
 
using namespace std;
 
struct gas_station{
    float price;
    int distance;
 
    bool operator < (const gas_station & A)const {
        return distance < A.distance;
    }
 
}buff[501];
int main()
{
    int Cmax,D,Davg,N;
    int dis;
    while(scanf("%d %d %d %d",&Cmax,&D,&Davg,&N)!=EOF){
        for(int i = 0; i < N; i++){
            scanf("%f %d",&buff[i].price,&buff[i].distance);
        }
        buff[N].distance = D;
        buff[N].price = 100000000;
 
        sort(buff,buff+N);
 
        if(buff[0].distance > 0){
            printf("The maximum travel distance = 0.00\n");
            continue;
        }
 
        dis = Cmax * Davg;//最大单次行车距离
        float sum = 0;//总费用
        float temp,remind_gas = 0;//剩余汽油量
        int i ,k;
        for(i = 0; i < N;i++){
            k = i+1;
            if(i != 0){
                remind_gas -= (float)(buff[i].distance-buff[i-1].distance)/Davg;
            }
            //找到当前站之后第一个价格比它低的加油站
            for(;k < N && buff[i].price <= buff[k].price;k++ )
                continue;
            if(buff[k].distance - buff[i].distance > dis){
                sum += (Cmax-remind_gas)*buff[i].price;
                remind_gas = Cmax;
            }else{
                temp = (float)(buff[k].distance-buff[i].distance)/Davg - remind_gas;
                if(fabs(temp)>1e-5&&temp >0){
                    sum += temp*buff[i].price;
                    remind_gas = (float)(buff[k].distance-buff[i].distance)/Davg;
                }
            }
 
 
            if(buff[i+1].distance - buff[i].distance>dis){
                double total_d = (double)(buff[i].distance + dis);
                printf("The maximum travel distance = %.2f\n",total_d);
                break;
            }
        }
        if(i==N){
            printf ("%.2f\n", sum);
        }
 
 
    }
    return 0;
}
 


注意:

比较浮点数是否大于零,需要加上fabs(temp),因为这个地方还wa了一次。







  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值