1033 To Fill or Not to Fill (25 分)

1033 To Fill or Not to Fill (25 分)

With highways available, driving a car from Hangzhou to any other city is easy. But since the tank capacity of a car is limited, we have to find gas stations on the way from time to time. Different gas station may give different price. You are asked to carefully design the cheapest route to go.

Input Specification:

Each input file contains one test case. For each case, the first line contains 4 positive numbers: C​max​​ (≤ 100), the maximum capacity of the tank; D (≤30000), the distance between Hangzhou and the destination city; D​avg​​ (≤20), the average distance per unit gas that the car can run; and N (≤ 500), the total number of gas stations. Then N lines follow, each contains a pair of non-negative numbers: P​i​​, the unit gas price, and D​i​​ (≤D), the distance between this station and Hangzhou, for i=1,⋯,N. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the cheapest price in a line, accurate up to 2 decimal places. It is assumed that the tank is empty at the beginning. If it is impossible to reach the destination, print The maximum travel distance = X where X is the maximum possible distance the car can run, accurate up to 2 decimal places.

Sample Input 1:

50 1300 12 8
6.00 1250
7.00 600
7.00 150
7.10 0
7.20 200
7.50 400
7.30 1000
6.85 300

Sample Output 1:

749.17

Sample Input 2:

50 1300 12 2
7.10 0
7.00 600

Sample Output 2:

The maximum travel distance = 1200.00
/*1033A*/
#include<cstdio>
#include<algorithm>
using namespace std;
const int maxn=510;
const int INF=1000000000;
struct station{
    double price;
    double dis;
}st[maxn];//用于存储每个加油站的油价和距起点的距离
bool cmp(station a,station b){
    return a.dis<b.dis;
}
int main(){
    double Cmax,D,Davg;
    int n;
    scanf("%lf%lf%lf%d",&Cmax,&D,&Davg,&n);
    for(int i=0;i<n;i++){
        scanf("%lf%lf",&st[i].price,&st[i].dis);
    }
    st[n].price=0;//设置终点的油价为0
    st[n].dis=D;//设置终点为dis为D的加油站
    sort(st,st+n,cmp);
    if(st[0].dis!=0){
        printf("The maximum travel distance = 0.00\n");
    }else{
        int now = 0;//当前所处的加油站的编号
        double ans = 0,nowTank = 0,MAX = Cmax*Davg;
        //花费的金额,油箱中还剩多少油,油箱加满最多能跑的距离
        while(now<n){
            int k=-1;//最低油价加油站的编号
            double priceMin = INF;//最低油价

            //选出从当前加油站加满能达到的范围内的第一个油价低于当前油价的加油站

            //如果没有低于当前油价的加油站,那么选价格最低的那个
            for(int i=now+1;i<=n&&st[i].dis-st[now].dis<=MAX;i++){
                if(st[i].price<priceMin){
                    priceMin = st[i].price;
                    k = i;
                    if(priceMin<st[now].price){
                        break;
                    }
                }
            }
            if(k==-1) break;//满油状态下无法找到加油站,退出循环

            //need为从now到k需要的油量
            double need=(st[k].dis-st[now].dis)/Davg;
            if(priceMin<st[now].price){//如果加油站k的油价低于当前油价,只买足够到k的油
                //如果当前优良不足need
                if(nowTank<need){
                    ans += (need-nowTank)*st[now].price;
                    nowTank = 0;//到达k后剩余油量为0
                }else{
                    nowTank -= need;
                }
            }else{//如果加油站k的油价高于当前油价,那么先加满
                ans += (Cmax-nowTank)*st[now].price;
                nowTank = Cmax - need;//到达k后剩余nowtank
            }
            now = k;
        }
        if(now == n){//如果跑到终点了输出花费
            printf("%0.2lf\n",ans);
        }else{//如果没跑到终点那么输出当前加油站的距离加上耗完满油油箱能跑的距离
            printf("The maximum travel distance = %0.2lf\n",st[now].dis+MAX);
        }

    }
    return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值