HDu1296(Polynomial Problem)多项式的求解

Polynomial Problem


Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 849    Accepted Submission(s): 330




Problem Description
We have learned how to obtain the value of a polynomial when we were a middle school student. If f(x) is a polynomial of degree n, we can let




If we have x, we can get f(x) easily. But a computer can not understand the expression like above. So we had better make a program to obtain f(x).
 


Input
There are multiple cases in this problem and ended by the EOF. In each case, there are two lines. One is an integer means x (0<=x<=10000), the other is an expression means f(x). All coefficients ai(0<=i<=n,1<=n<=10,-10000<=ai<=10000) are integers. A correct expression maybe likes
1003X^5+234X^4-12X^3-2X^2+987X-1000
 


Output
For each test case, there is only one integer means the value of f(x).



Sample Input
3
1003X^5+234X^4-12X^3-2X^2+987X-1000
 


Sample Output
264302






Notice that the writing habit of polynomial f(x) is usual such as
X^6+2X^5+3X^4+4X^3+5X^2+6X+7
-X^7-5X^6+3X^5-5X^4+20X^3+2X^2+3X+9
X+1
X^3+1
X^3
-X+1 etc. Any results of middle process are in the range from -1000000000 to 1000000000.

      

      这个题目我们队里称为水题,我看它的确是有难度啊。我也是参考了别人的代码才写出了的,

       看完之后,自我感觉程序不是很难,但是,就是思路要特别清晰。

       这个题目主要是说,给你一个多项式f(x)和常数a,叫你求出f(a)的结果;

                上代码……

#include<stdio.h>
#include<string.h>
char a[100005];
__int64 gg(__int64 x,__int64 y)
{
	__int64 i,ss=1;
	for(i=0;i<y;i++)
	{
		ss*=x;
	}
	return ss;
}
int main()
{
	__int64 s1,s2,i,l,x,s;char tt;
	while(~scanf("%I64d%s",&x,a))
	{ 
	
	    tt='+';
	    s1=s2=s=0;
		l=strlen(a);
		i=0;
		while(i<=l)
		{
			if(a[i]=='+'||a[i]=='-'||a[i]=='\0')
			{
				if(tt=='+')
				s+=s1*gg(x,s2);
				else
				s-=s1*gg(x,s2);
				s1=0;s2=0;
				tt=a[i];
				i++;
			}
		    else if(a[i]=='X')
			{
				if(s1==0)
				s1=1;
				i++;
				if(a[i]!='^')
				s2=1;
			}
			else if(a[i]=='^')
			{
				i++;
				while(1)
				{
					if(a[i]=='+'||a[i]=='-'||a[i]=='\0')
					break;
					s2=s2*10+(a[i]-'0');
					i++;
					
				}
			}
			else
			{
				s1=s1*10+(a[i]-'0');
				i++;
			}
		}
		printf("%I64d\n",s);
	}
	return 0;
 } 


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值