Polynomial Problem( HDU - 1296 表达式求值)

Problem Description
We have learned how to obtain the value of a polynomial when we were a middle school student. If f(x) is a polynomial of degree n, we can let
这里写图片描述
If we have x, we can get f(x) easily. But a computer can not understand the expression like above. So we had better make a program to obtain f(x).

Input
There are multiple cases in this problem and ended by the EOF. In each case, there are two lines. One is an integer means x (0<=x<=10000), the other is an expression means f(x). All coefficients ai(0<=i<=n,1<=n<=10,-10000<=ai<=10000) are integers. A correct expression maybe likes
1003X^5+234X^4-12X^3-2X^2+987X-1000

Output
For each test case, there is only one integer means the value of f(x).

Sample Input
3
1003X^5+234X^4-12X^3-2X^2+987X-1000

Sample Output
264302

Notice that the writing habit of polynomial f(x) is usual such as
X^6+2X^5+3X^4+4X^3+5X^2+6X+7
-X^7-5X^6+3X^5-5X^4+20X^3+2X^2+3X+9
X+1
X^3+1
X^3
-X+1 etc. Any results of middle process are in the range from -1000000000 to 1000000000.

#include<queue>
#include<stack>
#include<vector>
#include<math.h>
#include<cstdio>
#include<sstream>
#include<numeric>//STL数值算法头文件
#include<stdlib.h>
#include <ctype.h>
#include<string.h>
#include<iostream>
#include<algorithm>
#include<functional>//模板类头文件
using namespace std;

const int INF=0x3f3f3f3f;
const int maxn=110000;
typedef long long ll;

int main()
{
    int n,m, x, flag, mul, ans;
    char str[maxn];
    while(~scanf("%d",&x))
    {
        scanf("%s",str);
        int len = strlen(str);
        int num = -INF;
        flag = 1;
        ans = 0;
        for(int i = 0; i < len; i++)
        {
            if(str[i] == '-')
            {
                flag = 0;
                if(i + 1 < len && str[i + 1] == 'X')num = 1;
                continue;
            }
            if(str[i] == '+')
            {
                flag = 1;
                if(i + 1 < len && str[i + 1] == 'X')num = 1;
                continue;
            }
            if(str[i] == 'X')
            {
                if(i-1<0)num = 1;
                if(!flag)num = -num;
                flag = 1;
                if((i + 1 < len && str[i+1] != '^')||i+1>=len)ans += num*x, num = -INF;
                continue;
            }
            if(i - 1 >= 0 && str[i] >= '0' && str[i] <= '9' && str[i-1]== '^')
            {
                if(i + 1 < len && str[i+1] >= '0' && str[i+1]<= '9')
                {
                    mul = (str[i] -'0')*10 + str[i+1] - '0';
                    i++;
                }
                else mul = str[i] -'0';
                if(!flag)num = -num;
                flag = 1;
                int mid = x;
                for(int j = 2; j <= mul; j++)
                {
                    mid *= x;
                }
                ans += num * mid;
                num = -INF;
                continue;
            }
            if(str[i] >= '0' &&str[i] <= '9')
            {
                if(num == -INF)num = str[i] - '0';
                else num = num*10 + str[i] - '0';
            }

        }
        if(num != -INF)
        {
            if(!flag)num = -num;
            ans += num;
        }
        printf("%d\n",ans);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 2
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值