Highways

Highways
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 25117 Accepted: 11584

Description

The island nation of Flatopia is perfectly flat. Unfortunately, Flatopia has no public highways. So the traffic is difficult in Flatopia. The Flatopian government is aware of this problem. They're planning to build some highways so that it will be possible to drive between any pair of towns without leaving the highway system.

Flatopian towns are numbered from 1 to N. Each highway connects exactly two towns. All highways follow straight lines. All highways can be used in both directions. Highways can freely cross each other, but a driver can only switch between highways at a town that is located at the end of both highways.

The Flatopian government wants to minimize the length of the longest highway to be built. However, they want to guarantee that every town is highway-reachable from every other town.

Input

The first line of input is an integer T, which tells how many test cases followed.
The first line of each case is an integer N (3 <= N <= 500), which is the number of villages. Then come N lines, the i-th of which contains N integers, and the j-th of these N integers is the distance (the distance should be an integer within [1, 65536]) between village i and village j. There is an empty line after each test case.

Output

For each test case, you should output a line contains an integer, which is the length of the longest road to be built such that all the villages are connected, and this value is minimum.

Sample Input

1

3
0 990 692
990 0 179
692 179 0

Sample Output

692

Hint

Huge input,scanf is recommended.


我认为这应该是最简单的最小生成树了吧  我是刚开始学习最小生成树  自我认为其中对并查集的理解尤为重要  在没有做最小生成树题目之前 在书上我了解了一下Kruskal 算法,然后又在网上百度百科上借用上面的图深入理解Kruskal 算法  再看代码就没有那么难懂了 啊哈哈哈哈~~~~~



#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
#define P 550
int p[600];
struct node
{
    int a,b,len;
}s[P*P];
int cmp(struct node w,struct node m)
{
    return w.len<m.len;
}
int find(int x)
{
    if(x==p[x])
        return x;
    else
        return find(p[x]);
}
int main()
{
    int t,i,j,a1,a2,n,k;
    scanf("%d",&t);
    while(t--)
    {
        k=0;
        scanf("%d",&n);
        for(i=1;i<=n;i++)
        {
            for(j=1;j<=n;j++)
            {
                scanf("%d",&s[k].len);
                s[k].a=i;
                s[k].b=j;
                k++;
            }
        }
        sort(s,s+k,cmp);///给边排序
        for(i=1;i<=n;i++)///并查集里面用的数组初始化
            p[i]=i;
        int min_=0;
        for(i=0;i<k;i++)
        {
            a1=find(s[i].a);
            a2=find(s[i].b);
            if(a1!=a2)///不在一个集合中,<a1 a2为寻找的最终的根节点>
            {
                if(s[i].len>min_)
                    min_=s[i].len;
                p[a2]=a1;///就把 以a2为根节点的树和 以a1为根节点所在的树合并
            }
        }


        printf("%d\n",min_);
    }
    return 0;
}




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值