poj- 2503

Babelfish
Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 37006 Accepted: 15769

Description

You have just moved from Waterloo to a big city. The people here speak an incomprehensible dialect of a foreign language. Fortunately, you have a dictionary to help you understand them.

Input

Input consists of up to 100,000 dictionary entries, followed by a blank line, followed by a message of up to 100,000 words. Each dictionary entry is a line containing an English word, followed by a space and a foreign language word. No foreign word appears more than once in the dictionary. The message is a sequence of words in the foreign language, one word on each line. Each word in the input is a sequence of at most 10 lowercase letters.

Output

Output is the message translated to English, one word per line. Foreign words not in the dictionary should be translated as "eh".

Sample Input

dog ogday
cat atcay
pig igpay
froot ootfray
loops oopslay

atcay
ittenkay
oopslay

Sample Output

cat
eh
loops

Hint

Huge input and output,scanf and printf are recommended.

Source


题意:开始输入一本字典  每行输入英语单词   火星语.  然后有一个空行 下面输入的是需要查的火星语  输出对应的英语单词 如果没有英语单词 就输出"eh".

知识点: 1.map的初步学习<了解了映射 > 

2.sscanf的使用 拆分作用

  while(gets(s))
   {
       if(strlen(s)==0)
        break;
       sscanf(s,"%s%s",s1,s2);这里的sscanf把s这个串拆成s1和s2两个字符串  <也可以适用于拆分多个字符串 >
       m[s2]=s1;///映射
   }

3.还有用gets输入  当输入只有一个回车键的时候  这个串的长度是0  

#include<iostream>
#include<stdio.h>
#include<string.h>
#include<math.h>
#include<map>
#include<algorithm>
using namespace std;
char s[200],s1[200],s2[200];
int main()
{
    map< string,string >m;
   while(gets(s))
   {
       if(strlen(s)==0)
        break;
       sscanf(s,"%s%s",s1,s2);
       m[s2]=s1;
   }
   char a[200];
   while(gets(a))
   {
       if(m[a].length()==0)
       {
          puts("eh");
       }
       else
       {
           cout<<m[a]<<endl;
       }
   }
    return 0;
}







  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值