L3-014 周游世界

文章描述了一个问题,旅行社需要开发一个程序来自动规划旅行路线,考虑经停站最少和换乘次数最少的原则。程序使用深度优先搜索(DFS)来找到从起点到终点的最顺畅路线。
摘要由CSDN通过智能技术生成

周游世界是件浪漫事,但规划旅行路线就不一定了…… 全世界有成千上万条航线、铁路线、大巴线,令人眼花缭乱。所以旅行社会选择部分运输公司组成联盟,每家公司提供一条线路,然后帮助客户规划由联盟内企业支持的旅行路线。本题就要求你帮旅行社实现一个自动规划路线的程序,使得对任何给定的起点和终点,可以找出最顺畅的路线。所谓“最顺畅”,首先是指中途经停站最少;如果经停站一样多,则取需要换乘线路次数最少的路线。

输入格式:

输入在第一行给出一个正整数N(≤100),即联盟公司的数量。接下来有N行,第i行(i=1,⋯,N)描述了第i家公司所提供的线路。格式为:

M S[1] S[2] ⋯ S[M]

其中M(≤100)是经停站的数量,S[i](i=1,⋯,M)是经停站的编号(由4位0-9的数字组成)。这里假设每条线路都是简单的一条可以双向运行的链路,并且输入保证是按照正确的经停顺序给出的 —— 也就是说,任意一对相邻的S[i]和S[i+1](i=1,⋯,M−1)之间都不存在其他经停站点。我们称相邻站点之间的线路为一个运营区间,每个运营区间只承包给一家公司。环线是有可能存在的,但不会不经停任何中间站点就从出发地回到出发地。当然,不同公司的线路是可能在某些站点有交叉的,这些站点就是客户的换乘点,我们假设任意换乘点涉及的不同公司的线路都不超过5条。

在描述了联盟线路之后,题目将给出一个正整数K(≤10),随后K行,每行给出一位客户的需求,即始发地的编号和目的地的编号,中间以一空格分隔。

输出格式:

处理每一位客户的需求。如果没有现成的线路可以使其到达目的地,就在一行中输出“Sorry, no line is available.”;如果目的地可达,则首先在一行中输出最顺畅路线的经停站数量(始发地和目的地不包括在内),然后按下列格式给出旅行路线:

Go by the line of company #X1 from S1 to S2.
Go by the line of company #X2 from S2 to S3.
......

其中Xi是线路承包公司的编号,Si是经停站的编号。但必须只输出始发地、换乘点和目的地,不能输出中间的经停站。题目保证满足要求的路线是唯一的。

输入样例:

4
7 1001 3212 1003 1204 1005 1306 7797
9 9988 2333 1204 2006 2005 2004 2003 2302 2001
13 3011 3812 3013 3001 1306 3003 2333 3066 3212 3008 2302 3010 3011
4 6666 8432 4011 1306
4
3011 3013
6666 2001
2004 3001
2222 6666

输出样例:

2
Go by the line of company #3 from 3011 to 3013.
10
Go by the line of company #4 from 6666 to 1306.
Go by the line of company #3 from 1306 to 2302.
Go by the line of company #2 from 2302 to 2001.
6
Go by the line of company #2 from 2004 to 1204.
Go by the line of company #1 from 1204 to 1306.
Go by the line of company #3 from 1306 to 3001.
Sorry, no line is available.

 dfs

#include <iostream>
#include <vector>
#include <cstring>
using namespace std;

//dfs
#define INF 0x7fffffff
int n, op;
vector<int> arr[10005], ans;
int change, dis;
int vis[10005] = { 0 }, rou[10005][10005] = { 0 };
void dfs(vector<int>& p, int a, int b, int ch, int di) {
	if (a == b) {
		if (di < dis) change = ch, dis = di, ans = p;
		else if (di == dis && change > ch) change = ch, ans = p;
		return;
	}
	for (auto x : arr[a]) {
		if (vis[x]) continue;
		p.push_back(x), vis[x] = 1;
		if (p.size() <= 2 || (rou[p[p.size() - 1]][p[p.size() - 2]] == rou[p[p.size() - 2]][p[p.size() - 3]]))
			dfs(p, x, b, ch, di + 1);
		else
			dfs(p, x, b, ch + 1, di + 1);
		p.pop_back(), vis[x] = 0;
	}
	return;
}
void solve(int start, int eend) {
	memset(vis, 0, sizeof vis);
	vector<int> p;
	change = INF, dis = INF;
	p.push_back(start), vis[start] = 1;
	dfs(p, start, eend, 0, 0);
	p.pop_back(), vis[start] = 0;
	if (dis == INF) cout << "Sorry, no line is available." << endl;
	else {
		cout << dis << endl;
		int pos = 0, i = 0;
		for (i = 1; i < ans.size() - 1; i++) {
			if (i + 1 == ans.size() || rou[ans[i]][ans[i - 1]] == rou[ans[i]][ans[i + 1]]) continue;
			printf("Go by the line of company #%d from %04d to %04d.\n", rou[ans[i]][ans[i - 1]], ans[pos], ans[i]);
			pos = i;
		}
		printf("Go by the line of company #%d from %04d to %04d.\n", rou[ans[i]][ans[i - 1]], ans[pos], ans[i]);
	}
	return;
}
int main() {
	cin >> n;
	for (int i = 1, a, b; i <= n; i++) {
		cin >> a >> b;
		for (int j = 1, c; j < a; j++) {
			cin >> c;
			arr[b].push_back(c), arr[c].push_back(b);
			rou[b][c] = rou[c][b] = i;
			b = c;
		}
	}
	cin >> op;
	for (int i = 0, a, b; i < op; i++) {
		cin >> a >> b;
		solve(a, b);
	}
	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

云儿乱飘

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值