Find More Coins 解题报告

Eva loves to collect coins from all over the universe, including some other planets like Mars. One day she visited a universal shopping mall which could accept all kinds of coins as payments. However, there was a special requirement of the payment: for each bill, she must pay the exact amount. Since she has as many as 10​4​​ coins with her, she definitely needs your help. You are supposed to tell her, for any given amount of money, whether or not she can find some coins to pay for it.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive numbers: N (≤10​4​​, the total number of coins) and M (≤10​2​​, the amount of money Eva has to pay). The second line contains N face values of the coins, which are all positive numbers. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the face values V​1​​≤V​2​​≤⋯≤V​k​​ such that V​1​​+V​2​​+⋯+V​k​​=M. All the numbers must be separated by a space, and there must be no extra space at the end of the line. If such a solution is not unique, output the smallest sequence. If there is no solution, output "No Solution" instead.

Note: sequence {A[1], A[2], ...} is said to be "smaller" than sequence {B[1], B[2], ...} if there exists k≥1 such that A[i]=B[i] for all i<k, and A[k] < B[k].

Sample Input 1:

8 9
5 9 8 7 2 3 4 1

Sample Output 1:

1 3 5

Sample Input 2:

4 8
7 2 4 3

Sample Output 2:

No Solution

题目大意:用n个硬币买价值为m的东西,输出使用方案,使得正好几个硬币加起来价值为m。从小到大排列,输出最小的那个排列方案。

思路: 本来还以为是个多重部分和,最后才发现就是个01背包问题,果然是蒟蒻。。。

01背包问题,这个题就相当于重量跟价值是一样的,最大重量跟最大价值是一样的,这样就可以等价为一个01背包问题,这道题的难点在于如何统计步数,通过不断的递推更新used数组,从最小符合要求的used【?】【m】,开始计数,所得的序列即为最小序列,这里要求我们对原序列,进行从大到小的排列,以便我们进行统计,不理解的话可以尝试输出used数组最后储存的值!!!(推荐)

下面给出AC代码:

#include <bits/stdc++.h>
using namespace std;
typedef long long ll;
const int INF=0x3f3f3f3f;
const int maxn=1e4+10;
int n,m;
int a[maxn];
int d[maxn][110];
bool used[maxn][110];

int main()
{
    scanf("%d %d",&n,&m);
    for(int i=0;i<n;i++) scanf("%d",&a[i]);
    sort(a,a+n,greater<int>());

    for(int i=0;i<n;i++)
    {
        for(int j=0;j<=m;j++)
        {
            if(j<a[i]) d[i+1][j]=d[i][j];
            else if(d[i][j]<=d[i][j-a[i]]+a[i])
            {
                used[i+1][j]=true;
                d[i+1][j]=d[i][j-a[i]]+a[i];
            }
            else
            {
                d[i+1][j]=d[i][j];
            }
        }
    }

//    for(int i=0;i<=n;i++)
//    {
//        for(int j=0;j<=m;j++)
//        {
//            printf(" %d",used[i][j]);
//        }
//        printf("\n");
//    }


    if(d[n][m]==m)
    {
        vector<int> ans;
        int v=m,index=n;
        while(v>0)
        {
            if(used[index][v]==true)
            {
                ans.push_back(a[index-1]);
                v-=a[index-1];
            }
            index--;
        }

        for(int i=0;i<ans.size();i++)
            if(i) printf(" %d",ans[i]);
              else printf("%d",ans[i]);
    }
    else printf("No Solution");

    return 0;
}

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值