二叉搜索树的结构 解题报告

二叉搜索树或者是一棵空树,或者是具有下列性质的二叉树: 若它的左子树不空,则左子树上所有结点的值均小于它的根结点的值;若它的右子树不空,则右子树上所有结点的值均大于它的根结点的值;它的左、右子树也分别为二叉搜索树。(摘自百度百科)

给定一系列互不相等的整数,将它们顺次插入一棵初始为空的二叉搜索树,然后对结果树的结构进行描述。你需要能判断给定的描述是否正确。例如将{ 2 4 1 3 0 }插入后,得到一棵二叉搜索树,则陈述句如“2是树的根”、“1和4是兄弟结点”、“3和0在同一层上”(指自顶向下的深度相同)、“2是4的双亲结点”、“3是4的左孩子”都是正确的;而“4是2的左孩子”、“1和3是兄弟结点”都是不正确的。

输入格式:

输入在第一行给出一个正整数N(≤100),随后一行给出N个互不相同的整数,数字间以空格分隔,要求将之顺次插入一棵初始为空的二叉搜索树。之后给出一个正整数M(≤100),随后M行,每行给出一句待判断的陈述句。陈述句有以下6种:

  • A is the root,即"A是树的根";
  • A and B are siblings,即"AB是兄弟结点";
  • A is the parent of B,即"AB的双亲结点";
  • A is the left child of B,即"AB的左孩子";
  • A is the right child of B,即"AB的右孩子";
  • A and B are on the same level,即"AB在同一层上"。

题目保证所有给定的整数都在整型范围内。

输出格式:

对每句陈述,如果正确则输出Yes,否则输出No,每句占一行。

输入样例:

5
2 4 1 3 0
8
2 is the root
1 and 4 are siblings
3 and 0 are on the same level
2 is the parent of 4
3 is the left child of 4
1 is the right child of 2
4 and 0 are on the same level
100 is the right child of 3

输出样例:

Yes
Yes
Yes
Yes
Yes
No
No
No

直接说思路,这个题就是二叉搜索树的基本的建树查找过程,在下面代码中都会体现,比较基本,这道题最恶心的地方就是NULL的判断,各种判断,凡是涉及到的都必须判,漏掉任何一个都会RE。注意细节的实现。

还有就是注意这道题的读入方式如何去判断,一点点的判断去读,get新方法。

下面给出AC代码:

#include <bits/stdc++.h>
#include <cstdio>
#include <cstdlib>
#include <algorithm>
using namespace std;
typedef long long ll;
const int INF=0x3f3f3f3f;
const int maxn=1e6+10;
typedef struct node
{
    int data;
    node *left;
    node *right;
    node *parent;
}*BinTree;

void Build_Tree(BinTree &root,int num,BinTree rt)
{
    if(root==NULL)
    {
        root =new node();
        root->data=num;
        root->left=NULL;
        root->right=NULL;
        root->parent=rt;
        return;
    }

    if(root->data>num) Build_Tree(root->left,num,root);
    else Build_Tree(root->right,num,root);
}

BinTree Find(BinTree rt,int num)
{
    if(rt==NULL) return NULL;
    if(rt->data==num) return rt;

    if(rt->data>num) Find(rt->left,num);
    else  Find(rt->right,num);
}

int Getdeep(BinTree rt,int num,int cnt)
{
    if(rt==NULL) return 0;
    if(rt->data==num) return cnt;

    if(rt->data<num) Getdeep(rt->right,num,cnt+1);
    else Getdeep(rt->left,num,cnt+1);
}


int main()
{
    BinTree tree=NULL;

    int n; cin>>n;

    for(int i=0;i<n;i++)
    {
        int a; cin>>a;
        Build_Tree(tree,a,NULL);
    }

    int m; cin>>m;

    for(int i=0;i<m;i++)
    {
        int t1; string s1; cin>>t1>>s1;
        if(s1=="is")
        {
            string s2,s3; cin>>s2>>s3;
            if(s3=="root")
            {
                if(tree!=NULL&&tree->data==t1) printf("Yes\n");
                else printf("No\n");
            }
            else if(s3=="parent")
            {
                int t2; string s4; cin>>s4>>t2;
                BinTree t=Find(tree,t2);
                if(t!=NULL&&t->parent!=NULL&&t->parent->data==t1) printf("Yes\n");
                else printf("No\n");
            }
            else if(s3=="left")
            {
                int t2; string s4,s5; cin>>s4>>s5>>t2;
                BinTree t=Find(tree,t2);
                if(t!=NULL&&t->left!=NULL&&t->left->data==t1) printf("Yes\n");
                else printf("No\n");
            }
            else
            {
                int t2; string s4,s5; cin>>s4>>s5>>t2;
                BinTree t=Find(tree,t2);
                if(t!=NULL&&t->right!=NULL&&t->right->data==t1) printf("Yes\n");
                else printf("No\n");
            }

        }
        else
        {
            int t2; string s2,s3; cin>>t2>>s2>>s3;
            if(s3=="siblings")
            {
                node *t=Find(tree,t1);
                node *t1=Find(tree,t2);
                if(t!=NULL&&t1!=NULL&&t->parent!=NULL&&t1->parent!=NULL&&t->parent->data==t1->parent->data) printf("Yes\n");
                else printf("No\n");
            }
            else
            {
                string s4,s5,s6; cin>>s4>>s5>>s6;
//                cout<<"GG  "<<Getdeep(tree,t1,0)<<endl;
//                cout<<"GG1  "<<Getdeep(tree,t2,0)<<endl;
                if(Getdeep(tree,t1,0)==Getdeep(tree,t2,0)&&Getdeep(tree,t1,0)!=0) printf("Yes\n");
                else printf("No\n");
            }
        }
    }

    return 0;
}

 

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值