Hrbust 2327 Collection Game(思维)

Collection Game
Time Limit: 1000 MSMemory Limit: 128000 K
Total Submit: 92(39 users)Total Accepted: 40(35 users)Rating: Special Judge: No
Description
POI and POJ are pair of sisters, one is a master in “Kantai Collection”, another is an excellent competitor in ACM programming competition. One day, POI wants to visit POJ, and the pace that between their homes is made of square bricks. We can hypothesis that POI’s house is located in the NO.1 brick and POJ’s house is located in the NO.n brick. For POI, there are three ways she can choose to move in every step, go ahead one or two or three bricks. But some bricks are broken that couldn’t be touched. So, how many ways can POI arrive at POJ’s house?

Input

There are multiple cases.

In each case, the first line contains two integers N(1<=N<=10000) and M (1<=M<=100), respectively represent the sum of bricks, and broke bricks. Then, there are M number in the next line, the K-th number a[k](2<=a[k]<=n-1) means the brick at position a[k] was broke.

Output
Please output your answer P after mod 10007 because there are too many ways.
Sample Input

5 1

3

Sample Output
3
Source
"尚学堂杯"哈尔滨理工大学第七届程序设计竞赛

题意:上楼梯,起点在一阶,每次可走一阶两阶或三阶,但有一些台阶坏了不能走,问到第n阶楼梯有多少种走法。

思路:类似于斐波那契数列,a[i] = a[i-1] + a[i-2] + a[i-3] 。

#include<bits/stdc++.h>
using namespace std;
#define Mod 10007
const int N = 10000 + 10 ;
int a[N],b[N];
int main()
{
    int n,m;
    while(scanf("%d%d",&n,&m)==2)
    {
        memset(a,0,sizeof(a));
        memset(b,0,sizeof(b));
        for(int i=0;i<m;i++)
        {
            int x;
            scanf("%d",&x);
            b[x]=1;
        }
        a[2]=b[2]?0:1;
        a[3]=b[3]?0:a[2]+1;
        a[4]=b[4]?0:a[2]+a[3]+1;
        for(int i=5;i<=n;i++)
        {
            if(b[i])continue ;
            if(!b[i-1])
                a[i]+=a[i-1];
            if(!b[i-2])
                a[i]+=a[i-2];
            if(!b[i-3])
                a[i]+=a[i-3];
            a[i]%=Mod;
        }
        printf("%d\n",a[n]);
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值