HDU - 1016 Prime Ring Problem(dfs,素数环)

Prime Ring Problem

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 55512    Accepted Submission(s): 24583


Problem Description
A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.

Note: the number of first circle should always be 1.


 

Input
n (0 < n < 20).
 

Output
The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.

You are to write a program that completes above process.

Print a blank line after each case.
 

Sample Input
  
  
6 8
 

Sample Output
  
  
Case 1: 1 4 3 2 5 6 1 6 5 2 3 4 Case 2: 1 2 3 8 5 6 7 4 1 2 5 8 3 4 7 6 1 4 7 6 5 8 3 2 1 6 7 4 3 8 5 2
 

Source
 

Recommend
JGShining   |   We have carefully selected several similar problems for you:   1010  1241  1312  1072  1242 

题意:用1~n的n个数构成一个环,要求相邻两数相加为素数

直接dfs一发,用deque储存一下结果即可

#include <bits/stdc++.h>
using namespace std;

int n, p = 0;
int v[30];
int vis[50];

void xx(){
    for(int i = 1; i <= 40; i++){
        int flag = 0;
        for(int j = 2; j < i; j++){
            if(i%j == 0) flag = 1;
        }
        if(!flag) vis[i] = 1;
    }
}

deque<int> k;
void Dfs(int pos, int val){
    if(pos == n){
        if(!vis[val+1]) return;
        printf("1");
        int l = k.size(), x;
        for(int i = 0; i < l; i++){
            x = k.front();
            printf(" %d", x);
            k.pop_front();
            k.push_back(x);
        }
        printf("\n");
        return;
    }
    for(int i = 2; i <= n; i++){
        if(v[i]) continue;
        if(vis[i+val]){
            v[i] = 1;
            k.push_back(i);
            Dfs(pos+1, i);
            v[i] = 0;
            if(!k.empty()) k.pop_back();
        }
    }
}

int main(){
    xx();
    while(scanf("%d", &n) == 1){
        printf("Case %d:\n", ++p);
        Dfs(1, 1);
        printf("\n");
    }
}



  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值