ZOJ 3212 K-Nice(思维)



K-Nice

Time Limit: 1 Second       Memory Limit: 32768 KB       Special Judge

This is a super simple problem. The description is simple, the solution is simple. If you believe so, just read it on. Or if you don't, just pretend that you can't see this one.

We say an element is inside a matrix if it has four neighboring elements in the matrix (Those at the corner have two and on the edge have three). An element inside a matrix is called "nice" when its value equals the sum of its four neighbors. A matrix is called "k-nice" if and only if k of the elements inside the matrix are "nice".

Now given the size of the matrix and the value of k, you are to output any one of the "k-nice" matrix of the given size. It is guaranteed that there is always a solution to every test case.

Input

The first line of the input contains an integer T (1 <= T <= 8500) followed by T test cases. Each case contains three integers nmk (2 <= nm <= 15, 0 <= k <= (n - 2) * (m - 2)) indicating the matrix size n * m and it the "nice"-degree k.

Output

For each test case, output a matrix with n lines each containing m elements separated by a space (no extra space at the end of the line). The absolute value of the elements in the matrix should not be greater than 10000.

Sample Input

2
4 5 3
5 5 3

Sample Output

2 1 3 1 1
4 8 2 6 1
1 1 9 2 9
2 2 4 4 3
0 1 2 3 0
0 4 5 6 0
0 0 0 0 0
0 0 0 0 0
0 0 0 0 0


Author:  ZHUANG, Junyuan

Source: The 6th Zhejiang Provincial Collegiate Programming Contest


题意:若一个数等于其相邻四数加和,我们就称它为nice数,现要求我们构建一个n*m的矩阵,其中恰好有n个nice数。


#include<bits/stdc++.h>
using namespace std;
int a[20][20];
int main()
{
    int t;
    scanf("%d",&t);
    int n,m,k;
    while(t--)
    {
        scanf("%d%d%d",&n,&m,&k);
        memset(a,0,sizeof(a));
        int cnt=1,flag=0;
        k=(m-2)*(n-2)-k;
        for(int i=0;i<n-1;i++)
        {
            for(int j=1;j<m-1;j++)
            {
                if(cnt<=k)
                {
                    a[i][j]=cnt++;
                }
                else flag=1;
            }
            if(flag)
                break;
        }
        for(int i=0;i<n;i++)
        {
            for(int j=0;j<m;j++)
            {
                printf("%d%c",a[i][j],j<m-1?' ':'\n');
            }
        }
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值