PAT甲级 1006 Sign In and Sign Out(25) (模拟)

题目

At the beginning of every day, the first person who signs in the computer room will unlock the door, and the last one who signs out will lock the door. Given the records of signing in's and out's, you are supposed to find the ones who have unlocked and locked the door on that day.

输入

Each input file contains one test case. Each case contains the records for one day. The case starts with a positive integer M, which is the total number of records, followed by M lines, each in the format:

ID_number Sign_in_time Sign_out_time

where times are given in the format HH:MM:SS, and ID_number is a string with no more than 15 characters.

输出

For each test case, output in one line the ID numbers of the persons who have unlocked and locked the door on that day. The two ID numbers must be separated by one space.

Note: It is guaranteed that the records are consistent. That is, the sign in time must be earlier than the sign out time for each person, and there are no two persons sign in or out at the same moment.

样例输入 

3
CS301111 15:30:28 17:00:10
SC3021234 08:00:00 11:25:25
CS301133 21:45:00 21:58:40

样例输出 

SC3021234 CS301133

题意理解

输入n个id,然后每个id后面跟两个时间 前者是进入时间,后者是出去时间,最后找到在这一天中谁是开门的那个人,谁是关门的那个人,输出那两个人的id。题意十分简单,模拟一下即可,将时间当成字符串读入可以直接排序时间,找到最早的那个时间和最晚的那个时间,就是我们要输出的那两个人的id。

代码

#include<bits/stdc++.h>
using namespace std;
#define fx first 
#define fy second
typedef pair<string,string> PSS;
vector<string>ve;
unordered_map<string,string>in,out;
int n;
int main(){
    scanf("%d",&n);
    for(int i=0;i<n;i++){
        string id;
        PSS t;
        cin>>id>>t.fx>>t.fy;
        ve.push_back(t.fx);
        ve.push_back(t.fy);
        in[t.fx]=id;out[t.fy]=id;
    }
    sort(ve.begin(),ve.end());
    cout<<in[ve[0]]<<" "<<out[ve[ve.size()-1]]<<endl;
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值