PAT甲级 1009 Product of Polynomials(25) (模拟)

题目

This time, you are supposed to find A×B where A and B are two polynomials.

输入

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:

K N1​ aN1​​ N2​ aN2​​ ... NK​ aNK​​

where K is the number of nonzero terms in the polynomial, Ni​ and aNi​​ (i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10, 0≤NK​<⋯<N2​<N1​≤1000.

输出

For each test case you should output the product of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate up to 1 decimal place.

样例输入 

2 1 2.4 0 3.2
2 2 1.5 1 0.5

样例输出 

3 3 3.6 2 6.0 1 1.6

题意理解

这题就是输入两个多项式然后模拟一下即可,题目比较水就不再细讲了,详情看代码吧

代码 

#include<bits/stdc++.h>
using namespace std;
const int N=2010;
double a[N],b[N],c[N];
void solve(){
    int n;
    cin>>n;
    for(int i=0;i<n;i++){
        int x;double x1;
        cin>>x>>x1;
        a[x]+=x1;
    }
    cin>>n;
    for(int i=0;i<n;i++){
        int x;double x1;
        cin>>x>>x1;
        b[x]+=x1;
    }
    for(int i=0;i<N;i++){
        if(a[i]!=0.0){
            for(int j=0;j<N;j++){
                if(b[j]!=0.0){
                    c[i+j]+=a[i]*b[j];
                }
            }
        }
    }
    int cnt=0;
    for(int i=0;i<N;i++){
        if(c[i]!=0.0)
            cnt++;
    }
    cout<<cnt;
    for(int i=N;i>=0;i--){
        if(c[i]!=0.0){
            cout<<" "<<i;
            printf(" %0.1lf",c[i]);
        }
    }
    return;
}
int main(){
    int T=1;
    //cin>>T;
    while(T--){
        solve();
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值