PAT甲级 1036 Boys vs Girls(25) (STL+哈希)

题目

This time you are asked to tell the difference between the lowest grade of all the male students and the highest grade of all the female students.

输入

Each input file contains one test case. Each case contains a positive integer N, followed by N lines of student information. Each line contains a student's namegenderID and grade, separated by a space, where name and ID are strings of no more than 10 characters with no space, gender is either F (female) or M (male), and grade is an integer between 0 and 100. It is guaranteed that all the grades are distinct.

输出

For each test case, output in 3 lines. The first line gives the name and ID of the female student with the highest grade, and the second line gives that of the male student with the lowest grade. The third line gives the difference gradeF​−gradeM​. If one such kind of student is missing, output Absent in the corresponding line, and output NA in the third line instead.

样例输入 

样例输入1:

3
Joe M Math990112 89
Mike M CS991301 100
Mary F EE990830 95

样例输入2:

1
Jean M AA980920 60

样例输出 

样例输出1:

Mary EE990830
Joe Math990112
6

样例输出2:

Absent
Jean AA980920
NA

题意理解

给你n个人

名字 性别 ID 和 成绩

你要在在这些中找到

女生中成绩最高的 输出名字和ID

男生中成绩最低的 输出名字和ID

那么我们直接放入哈希表里面查表即可

都放入学生表里面 记录这个性别中最大的成绩和名字

如果没找到 也就是没有这个性别的同学 那么我们特判一下即可

最后还要输出一行 最大成绩和最小成绩的差值

题意比较简单

代码  

#include<bits/stdc++.h>
using namespace std;
const int INF=0x3f3f3f3f;
typedef pair<string,int> PSI;
map<string,string>student;
int min_grade=INF,max_grade=-INF;
int main(){
    int n;
    cin>>n;
    string bo,gi;
    int fl1=0,fl2=0;
    while(n--){
        string name,sex,id;
        int grade;
        cin>>name>>sex>>id>>grade;
        if(sex=="F"){
           if(max_grade<grade){
               max_grade=grade;
               gi=name;
               fl1=1;
           }    
        }
        else {
            if(min_grade>grade){
                min_grade=grade;
                bo=name;
                fl2=1;
            }
        }
        student[name]=id;
    }
    if(fl1)cout<<gi<<" "<<student[gi]<<endl;
    else cout<<"Absent"<<endl;
    
    if(fl2)cout<<bo<<" "<<student[bo]<<endl;
    else cout<<"Absent"<<endl;
    
    if(!fl1||!fl2){
      cout<<"NA"<<endl;
    }
    else cout<<abs(max_grade-min_grade)<<endl;
    
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值