PAT甲级 1039 Course List for Student(25) (STL+哈希)

题目

Zhejiang University has 40000 students and provides 2500 courses. Now given the student name lists of all the courses, you are supposed to output the registered course list for each student who comes for a query.

输入

Each input file contains one test case. For each case, the first line contains 2 positive integers: N (≤40,000), the number of students who look for their course lists, and K (≤2,500), the total number of courses. Then the student name lists are given for the courses (numbered from 1 to K) in the following format: for each course i, first the course index i and the number of registered students N_{i} (≤200) are given in a line. Then in the next line, N_{i}​ student names are given. A student name consists of 3 capital English letters plus a one-digit number. Finally the last line contains the N names of students who come for a query. All the names and numbers in a line are separated by a space.

输出

For each test case, print your results in N lines. Each line corresponds to one student, in the following format: first print the student's name, then the total number of registered courses of that student, and finally the indices of the courses in increasing order. The query results must be printed in the same order as input. All the data in a line must be separated by a space, with no extra space at the end of the line.

样例输入 

11 5
4 7
BOB5 DON2 FRA8 JAY9 KAT3 LOR6 ZOE1
1 4
ANN0 BOB5 JAY9 LOR6
2 7
ANN0 BOB5 FRA8 JAY9 JOE4 KAT3 LOR6
3 1
BOB5
5 9
AMY7 ANN0 BOB5 DON2 FRA8 JAY9 KAT3 LOR6 ZOE1
ZOE1 ANN0 BOB5 JOE4 JAY9 FRA8 DON2 AMY7 KAT3 LOR6 NON9

样例输出 

ZOE1 2 4 5
ANN0 3 1 2 5
BOB5 5 1 2 3 4 5
JOE4 1 2
JAY9 4 1 2 4 5
FRA8 3 2 4 5
DON2 2 4 5
AMY7 1 5
KAT3 3 2 4 5
LOR6 4 1 2 4 5
NON9 0

题意理解

给你n个询问 m条读入

每条读入信息是

课程号 选课人数

每个学生的姓名

最后一共n个姓名询问 输出这个学生的姓名 选的课程数目 具体是哪些课程数目

那么我们只要把姓名映射成id即可 然后放入哈希表里面去查表就好 为了防止超时

统一用scanf 读入 printf 打印

代码 

#include<bits/stdc++.h> 
using namespace std;
typedef long long LL;
typedef unsigned long long ULL ;
typedef pair<int,int> PII;
typedef pair<double,double> PDD;
#define fx first
#define fy second
#define io ios::sync_with_stdio(0),cin.tie(0),cout.tie(0);
const int INF=0x3f3f3f3f;
const double DINF=0x7f7f7f7f;
const LL  LINF=1e18;
const int N=1e3+10;
const int M=2e2+10;
const int MOD=1e9+7;
int n,m;
int id;
unordered_map<string,int>st;
unordered_map<int,vector<int> >ans;
int main(){
    scanf("%d%d",&n,&m);
    string name;
    name.resize(11);
    while(m--){
        int x,nu;
        scanf("%d%d",&x,&nu);
        getchar();
        while(nu--){
            scanf("%s",&name[0]);
            if(!st[name])st[name]=++id;
            ans[st[name]].push_back(x);
        }
    }
    
    for(int i=1;i<=n;i++){
        scanf("%s",&name[0]);
        sort(ans[st[name]].begin(),ans[st[name]].end());
        printf("%s %d",name.c_str(),ans[st[name]].size());
        
        for(auto tmp:ans[st[name]]){
            printf(" %d",tmp);
        }
        
        puts("");
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值