PAT甲级 1037 Magic Coupon(25) (贪心)

题目

The magic shop in Mars is offering some magic coupons. Each coupon has an integer N printed on it, meaning that when you use this coupon with a product, you may get N times the value of that product back! What is more, the shop also offers some bonus product for free. However, if you apply a coupon with a positive N to this bonus product, you will have to pay the shop N times the value of the bonus product... but hey, magically, they have some coupons with negative N's!

For example, given a set of coupons { 1 2 4 −1 }, and a set of product values { 7 6 −2 −3 } (in Mars dollars M$) where a negative value corresponds to a bonus product. You can apply coupon 3 (with N being 4) to product 1 (with value M$7) to get M$28 back; coupon 2 to product 2 to get M$12 back; and coupon 4 to product 4 to get M$3 back. On the other hand, if you apply coupon 3 to product 4, you will have to pay M$12 to the shop.

Each coupon and each product may be selected at most once. Your task is to get as much money back as possible.

输入

Each input file contains one test case. For each case, the first line contains the number of coupons N_{C}​, followed by a line with N_{C}​ coupon integers. Then the next line contains the number of products N_{P}​, followed by a line with NP​ product values. Here 1≤N_{C}​,N_{P}​≤10^{5}, and it is guaranteed that all the numbers will not exceed 2^{30}.

输出

For each test case, simply print in a line the maximum amount of money you can get back.

样例输入 

4
1 2 4 -1
4
7 6 -2 -3

样例输出 

43

题意理解

你有n张优惠券

然后输入优惠券的值 有正有负

商店有m个货物

然后输入货物的值 有正有负

如果你的优惠券是正的 货物值也是正的 那么你可以获得 优惠券乘以货物值的价值

如果优惠券是负的 货物值是正的 那么你就要赔偿 优惠券乘以货物值的价值

如果都是负的 那么也是可以获得 优惠券乘以货物值的价值

最后问你 你能带走的最大价值是多少

一句话总计题意 正的乘以正的 负的乘以负的 我们才能保证带走的都是正值

那么我们贪心的考虑

最大的和最大的正数 才能获得最大收益

最小的负数和最小的负数 才能获得最大收益

那么我们直接排个序然后将正数乘积和负数乘积都处理出来然后累加即可

代码 

#include<bits/stdc++.h> 
using namespace std;
typedef long long LL;
typedef unsigned long long ULL ;
typedef pair<int,int> PII;
typedef pair<double,double> PDD;
#define fx first
#define fy second
#define io ios::sync_with_stdio(0),cin.tie(0),cout.tie(0);
const int INF=0x3f3f3f3f;
const double DINF=0x7f7f7f7f;
const LL  LINF=1e18;
const int N=1e3+10;
const int M=2e2+10;
const int MOD=1e9+7;
int n,m;
LL sum=0,x;
vector<LL>pt,co;
bool cmp(LL a,LL b){
    return a>b;
}
int main(){
    scanf("%d",&n);
    for(int i=0;i<n;i++){
        cin>>x;
        co.push_back(x);
    }
    scanf("%d",&m);
    for(int i=0;i<m;i++){
        cin>>x;
        pt.push_back(x);
    }
    sort(co.begin(),co.end(),cmp);
    sort(pt.begin(),pt.end(),cmp);
    
    for(int i=0;i<co.size()&&i<pt.size();i++){
        if(co[i]>0&&pt[i]>0){
            sum+=co[i]*pt[i];
        }
        else break;
    }
    
    reverse(co.begin(),co.end());
    reverse(pt.begin(),pt.end());
    
    for(int i=0;i<co.size()&&i<pt.size();i++){
        if(co[i]<0&&pt[i]<0){
            sum+=co[i]*pt[i];
        }
        else break;
    }
    
    cout<<sum<<endl;
    
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值