The magic shop in Mars is offering some magic coupons. Each coupon has an integer N printed on it, meaning that when you use this coupon with a product, you may get N times the value of that product back! What is more, the shop also offers some bonus product for free. However, if you apply a coupon with a positive N to this bonus product, you will have to pay the shop N times the value of the bonus product... but hey, magically, they have some coupons with negative N's!
For example, given a set of coupons { 1 2 4 −1 }, and a set of product values { 7 6 −2 −3 } (in Mars dollars M$) where a negative value corresponds to a bonus product. You can apply coupon 3 (with N being 4) to product 1 (with value M$7) to get M$28 back; coupon 2 to product 2 to get M$12 back; and coupon 4 to product 4 to get M$3 back. On the other hand, if you apply coupon 3 to product 4, you will have to pay M$12 to the shop.
Each coupon and each product may be selected at most once. Your task is to get as much money back as possible.
Input Specification:
Each input file contains one test case. For each case, the first line contains the number of coupons NC, followed by a line with NC coupon integers. Then the next line contains the number of products NP, followed by a line with NP product values. Here 1≤NC,NP≤105, and it is guaranteed that all the numbers will not exceed 230.
Output Specification:
For each test case, simply print in a line the maximum amount of money you can get back.
Sample Input:
4
1 2 4 -1
4
7 6 -2 -3
Sample Output:
43
题目大意
这题就是说给出两个数组,数组中有正数有负数,然后两个数组各取出数个元素对应相乘求和,求最大的和。
个人思路
这题是贪心算法,就贪最大乘积,也就是最大正数乘最大正数,最小负数乘最小负数,不进行正负数相乘,然后求和。
代码实现
#include <cstdio>
#include <algorithm>
#include <iostream>
#define ll long long
using namespace std;
const int maxn = 100005;
ll coupons[maxn], products[maxn];
bool cmp(const int a, const int b) {
return a > b;
}
int main() {
// 输入
int nc, np;
cin >> nc;
for (int i = 0; i < nc; i ++) {
cin >> coupons[i];
}
cin >> np;
for (int i = 0; i < np; i ++) {
cin >> products[i];
}
// 从大到小排序
sort(coupons, coupons+nc, cmp);
sort(products, products+np, cmp);
// 将正正相乘和负负相乘求和
ll ans = 0;
for (int i = 0; coupons[i] > 0 && i < nc; i ++) {
if (products[i] <= 0) break;
ans += coupons[i]*products[i];
}
for (int i = nc-1, j = np-1; coupons[i] < 0 && i >= 0 && products[j] < 0 && j >= 0; i --) {
ans += coupons[i]*products[j--];
}
// 输出
cout << ans << endl;
return 0;
}
总结
学习不息,继续加油