PAT甲级 1055 The World‘s Richest(25) (结构体排序)

题目

Forbes magazine publishes every year its list of billionaires based on the annual ranking of the world's wealthiest people. Now you are supposed to simulate this job, but concentrate only on the people in a certain range of ages. That is, given the net worths of N people, you must find the M richest people in a given range of their ages.

输入

Each input file contains one test case. For each case, the first line contains 2 positive integers: N (≤10^{5}) - the total number of people, and K (≤10^{3}) - the number of queries. Then N lines follow, each contains the name (string of no more than 8 characters without space), age (integer in (0, 200]), and the net worth (integer in [−10^{6},10^{6}]) of a person. Finally there are K lines of queries, each contains three positive integers: M (≤100) - the maximum number of outputs, and [AminAmax] which are the range of ages. All the numbers in a line are separated by a space.

输出

For each query, first print in a line Case #X: where X is the query number starting from 1. Then output the M richest people with their ages in the range [AminAmax]. Each person's information occupies a line, in the format

Name Age Net_Worth

The outputs must be in non-increasing order of the net worths. In case there are equal worths, it must be in non-decreasing order of the ages. If both worths and ages are the same, then the output must be in non-decreasing alphabetical order of the names. It is guaranteed that there is no two persons share all the same of the three pieces of information. In case no one is found, output None.

样例输入 

12 4
Zoe_Bill 35 2333
Bob_Volk 24 5888
Anny_Cin 95 999999
Williams 30 -22
Cindy 76 76000
Alice 18 88888
Joe_Mike 32 3222
Michael 5 300000
Rosemary 40 5888
Dobby 24 5888
Billy 24 5888
Nobody 5 0
4 15 45
4 30 35
4 5 95
1 45 50

样例输出 

Case #1:
Alice 18 88888
Billy 24 5888
Bob_Volk 24 5888
Dobby 24 5888
Case #2:
Joe_Mike 32 3222
Zoe_Bill 35 2333
Williams 30 -22
Case #3:
Anny_Cin 95 999999
Michael 5 300000
Alice 18 88888
Cindy 76 76000
Case #4:
None

题意理解

给你n个人 m个询问

每个人有三个属性 人名 年龄 财富

优先按照财富排降序 如果财富一样 按照年龄排升序 如果都一样 最后按照名字排字典序

m个询问

个数 年龄左区间 年龄右区间

在这个年龄区间的最多输出人数

如果没有那就输出None 那么我们直接重写一下cmp 然后排个序就好 结构体比较方便

代码 

#include<bits/stdc++.h>
using namespace std;
const int N=2e5+10;
int n,m;
typedef struct pe{
    string name;
    int age,money;
}pe;
pe person[N];
bool cmp(pe a,pe b){
    if(a.money==b.money){
        if(a.age==b.age){
            return a.name<b.name;
        }
        else return a.age<b.age;
    }
    else return a.money>b.money;
}
int main(){
    scanf("%d%d",&n,&m);
    for(int i=0;i<n;i++){
        cin>>person[i].name;
        scanf("%d%d",&person[i].age,&person[i].money);
    }
    sort(person,person+n,cmp);
    for(int i=1;i<=m;i++){
        int nu,l,r;
        scanf("%d%d%d",&nu,&l,&r);
        int cnt=nu;
        printf("Case #%d:\n",i);
        for(int j=0;j<n;j++){
            if(person[j].age>=l&&person[j].age<=r){
                cnt--;
                cout<<person[j].name;
                printf(" %d %d\n",person[j].age,person[j].money);
            }
            if(cnt==0)break;
        }
        if(cnt==nu)puts("None");
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值