PAT甲级1055:The World‘s Richest (25)

题目

Forbes magazine publishes every year its list of billionaires based on the annual ranking of the world’s wealthiest people. Now you are supposed to simulate this job, but concentrate only on the people in a certain range of ages. That is, given the net worths of N people, you must find the M richest people in a given range of their ages.

Input Specification:
Each input file contains one test case. For each case, the first line contains 2 positive integers: N (≤105) - the total number of people, and K (≤103) - the number of queries. Then N lines follow, each contains the name (string of no more than 8 characters without space), age (integer in (0, 200]), and the net worth (integer in [−106,106]) of a person. Finally there are K lines of queries, each contains three positive integers: M (≤100) - the maximum number of outputs, and [Amin, Amax] which are the range of ages. All the numbers in a line are separated by a space.

Output Specification:
For each query, first print in a line Case #X: where X is the query number starting from 1. Then output the M richest people with their ages in the range [Amin, Amax]. Each person’s information occupies a line, in the format

Name Age Net_Worth
The outputs must be in non-increasing order of the net worths. In case there are equal worths, it must be in non-decreasing order of the ages. If both worths and ages are the same, then the output must be in non-decreasing alphabetical order of the names. It is guaranteed that there is no two persons share all the same of the three pieces of information. In case no one is found, output None.

Sample Input:

12 4
Zoe_Bill 35 2333
Bob_Volk 24 5888
Anny_Cin 95 999999
Williams 30 -22
Cindy 76 76000
Alice 18 88888
Joe_Mike 32 3222
Michael 5 300000
Rosemary 40 5888
Dobby 24 5888
Billy 24 5888
Nobody 5 0
4 15 45
4 30 35
4 5 95
1 45 50

Sample Output:

Case #1:
Alice 18 88888
Billy 24 5888
Bob_Volk 24 5888
Dobby 24 5888
Case #2:
Joe_Mike 32 3222
Zoe_Bill 35 2333
Williams 30 -22
Case #3:
Anny_Cin 95 999999
Michael 5 300000
Alice 18 88888
Cindy 76 76000
Case #4:
None

解题思路

首先想到的是(错误思路,可以跳过不看)先将所有人按照年龄升序排列,然后遍历结构体数组,记录各个年龄的第一个人所在的下标(如果未出现该年龄,用其后最接近的年龄的那个人的下标);之后每读入一个,读取所有年龄在 [Amin, Amax] 范围内的人的结点存入vector,排序(按照资产降序>年龄升序>姓名字典序)后输出min(要求输出人的个数,符合要求人的个数)个人的信息,但是测试点2运行超时(错误代码贴在文末错误代码部分)。

以上思路的错误原因是:排序耗时过长,极端情况下,可能需要在一次查询中对105个人的信息进行排序,但实际需要输出的个数M ≤100 ( the maximum number of outputs),即只需要输出资产最多的那100个人,这样的情况下排序是十分浪费时间的方法。

因此,我们希望能够在需要输出的数据量M(最大为100)和符合年龄范围的人数相差很大时,尽可能的减少筛选和排序的时间。我们直到qsort时间复杂度是n* log(n),当需要排序的人的信息很多时,它的用时会大于for循环,因此,我们的原则是在qsort和for之间,优先选择for。

这样,正确的思路就可以是:首先读入数据后,对所有数据进行一次qsort排序(按照资产降序>年龄升序>姓名字典序),遍历排序后的数组,将人的信息存入vector数组A,遍历时统计各个年龄段的人的人数,如果某一年龄人数超过100,则不需要再放入(因为最多输出就是100);之后读入查询信息,每读入一条,遍历A,输出最先查找到的M个人结束运行,或输出所有符合要求的不足M条的信息。

代码

#include<bits/stdc++.h>
using namespace std;

int Hash[200];
struct people{
    char name[9];//string of no more than 8 characters without space
    int age;//(0,200]
    int nw;//the net worth, integer in [−10^6,10^6]
};

int cmp1(const void *a, const void *b){
    struct people c = *(struct people*)a;
    struct people d = *(struct people*)b;
    if (c.nw!=d.nw)//资产多的在前
        return (c.nw>d.nw)?-1:1;
    else
    {
        if (c.age!=d.age)//年龄小的在前
            return (c.age<d.age)?-1:1;
        else //以上两项相同,按照名字字典顺序输出
            return (strcmp(c.name,d.name)<0)?-1:1;
    }
}

int main(){
    int i,j,N,K,k=0,t,t1,t2,temp;//N总人数,K查询次数
    scanf("%d %d",&N,&K);
    struct people P[N];
    vector <people> p;
    for (i=0;i<N;i++)
        scanf("%s %d %d",P[i].name,&P[i].age,&P[i].nw);
    qsort(P,N,sizeof(P[0]),cmp1);//资产降序>年龄升序>姓名字典序
    for (i=0;i<N;i++)//将每个年龄段的前100名存入vector
    {
        if (Hash[P[i].age]<100)
        {
            k++;
            Hash[P[i].age]++;//该年龄的人数增加
            p.push_back(P[i]);
        }
    }
    for (i=1;i<=K;i++)
    {
        t = 0;//记录输出人数
        scanf("%d %d %d",&temp,&t1,&t2);
        printf("Case #%d:\n",i);
        for (j=0;j<k;j++)
        {
            if (p[j].age<=t2 && p[j].age>=t1)
            {
                printf("%s %d %d\n",p[j].name,p[j].age,p[j].nw);
                if ((++t)==temp)
                    break;
            }
        }
        if (t==0)
            printf("None");
    }
    return 0;
}

错误代码

测试点2运行超时(22分):

#include<bits/stdc++.h>
using namespace std;

int t1,t2,Hash[200];
struct people{
    char name[9];//string of no more than 8 characters without space
    int age;//(0,200]
    int nw;//the net worth, integer in [−10^6,10^6]
};

int cmp1(const void *a, const void *b){
    struct people c = *(struct people *)a;
    struct people d = *(struct people *)b;
    return c.age-d.age;//年龄升序
}

bool cmp2(people c, people d){
    if (c.nw!=d.nw)//资产多的在前
        return (c.nw>d.nw);
    else
    {
        if (c.age!=d.age)//年龄小的在前
            return (c.age<d.age);
        else //以上两项相同,按照名字字典顺序输出
            return (strcmp(c.name,d.name)<0);
    }
}

int min(int a, int b){
    return (a>b)?b:a;
}

int main(){
    int i,j,N,K,temp;//N总人数,K查询次数
    scanf("%d %d",&N,&K);
    struct people P[N];
    for (i=0;i<N;i++)
        scanf("%s %d %d",P[i].name,&P[i].age,&P[i].nw);
    qsort(P,N,sizeof(P[0]),cmp1);//年龄升序
    Hash[P[0].age] = 0;//初始化
    for (i=1;i<N;i++)
    {
        if (P[i].age!=P[i-1].age)
        {
            Hash[P[i].age] = i;//记录下标
            for (j=P[i].age-1;j>P[i-1].age;j--)//补齐一些没有人的年龄的下标
                Hash[j] = i;
        }
    }
    for (i=1;i<=K;i++)
    {
        scanf("%d %d %d",&temp,&t1,&t2);
        printf("Case #%d:\n",i);
        vector <people> p;//存放符合年轻范围要求的人的信息
        for (j=Hash[t1];j<N;j++)
        {
            if (P[j].age<=t2)
                p.push_back(P[j]);
            else //P[j].age>t2,后面的一定不在min-max的年龄范围
                break;
        }
        if (p.size()==0)
            printf("None");
        else
        {
            sort(p.begin(),p.end(),cmp2);
            for (j=0;j<min(temp,p.size());j++)
                printf("%s %d %d\n",p[j].name,p[j].age,p[j].nw);
        }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值