PAT甲级 1126 Eulerian Path(25) (并查集)

题目

In graph theory, an Eulerian path is a path in a graph which visits every edge exactly once. Similarly, an Eulerian circuit is an Eulerian path which starts and ends on the same vertex. They were first discussed by Leonhard Euler while solving the famous Seven Bridges of Konigsberg problem in 1736. It has been proven that connected graphs with all vertices of even degree have an Eulerian circuit, and such graphs are called Eulerian. If there are exactly two vertices of odd degree, all Eulerian paths start at one of them and end at the other. A graph that has an Eulerian path but not an Eulerian circuit is called semi-Eulerian. (Cited from https://en.wikipedia.org/wiki/Eulerian_path)

Given an undirected graph, you are supposed to tell if it is Eulerian, semi-Eulerian, or non-Eulerian.

输入

Each input file contains one test case. Each case starts with a line containing 2 numbers N (≤ 500), and M, which are the total number of vertices, and the number of edges, respectively. Then M lines follow, each describes an edge by giving the two ends of the edge (the vertices are numbered from 1 to N).

输出

For each test case, first print in a line the degrees of the vertices in ascending order of their indices. Then in the next line print your conclusion about the graph -- either EulerianSemi-Eulerian, or Non-Eulerian. Note that all the numbers in the first line must be separated by exactly 1 space, and there must be no extra space at the beginning or the end of the line.

样例输入 

样例输入1:

7 12
5 7
1 2
1 3
2 3
2 4
3 4
5 2
7 6
6 3
4 5
6 4
5 6

样例输入2:

6 10
1 2
1 3
2 3
2 4
3 4
5 2
6 3
4 5
6 4
5 6

样例输入3:

5 8
1 2
2 5
5 4
4 1
1 3
3 2
3 4
5 3

样例输出 

样例输出1:

2 4 4 4 4 4 2
Eulerian

样例输出2:

2 4 4 4 3 3
Semi-Eulerian

样例输出3:

3 3 4 3 3
Non-Eulerian

题意理解

给你 n个点 m条边 是无向图 

让你判断这个图是什么类型的

如果这个是连通图 那么每个点度数都是偶数 的话

这个图就是欧拉图 输出 Eulerian

如果这个图是连通图 只有两个点度数是奇数 其余点度数都是偶数的话 

这个图就是半欧拉图 输出 Semi-Eulerian

那么其余输出

Non-Eulerian

图的连通性很好判

我们直接用并查集维护图的连通性即可 只要某个连通块的点的个数到了n 那么一定是一个连通的图 

反之如果找不到这样的连通子图的话 就是不连通的图

无论是什么类型的图 都要先输出结点的度

代码 

#include<bits/stdc++.h>
using namespace std;
const int N=1e5+10;
int ae[N],siz[N],d[N];
int n,m;
int cnt,fl;
void init(){
    for(int i=1;i<=n;i++){
        ae[i]=i;
        siz[i]=1;
    }
}
int find(int x){
    if(ae[x]!=x)ae[x]=find(ae[x]);
    return ae[x];
}
void merge(int a,int b){
    a=find(a);b=find(b);
    if(a!=b){
       ae[a]=b;
       siz[b]+=siz[a];
    }
}
int main(){
    scanf("%d%d",&n,&m);
    init();
    while(m--){
        int a,b;
        scanf("%d%d",&a,&b);
        merge(a,b);
        d[a]++;d[b]++;
    }
    for(int i=1;i<=n;i++){
        if(d[i]%2)cnt++;
        if(siz[i]==n)fl=1;
        if(i>1)printf(" ");
        printf("%d",d[i]);
    }
    puts("");
    if(fl&&!cnt)puts("Eulerian");
    else if(fl&&cnt==2)puts("Semi-Eulerian");
    else puts("Non-Eulerian");
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值