PAT甲级 1062 Talent and Virtue(25) (结构体排序)

题目

About 900 years ago, a Chinese philosopher Sima Guang wrote a history book in which he talked about people's talent and virtue. According to his theory, a man being outstanding in both talent and virtue must be a "sage(圣人)"; being less excellent but with one's virtue outweighs talent can be called a "nobleman(君子)"; being good in neither is a "fool man(愚人)"; yet a fool man is better than a "small man(小人)" who prefers talent than virtue.

Now given the grades of talent and virtue of a group of people, you are supposed to rank them according to Sima Guang's theory.

输入

Each input file contains one test case. Each case first gives 3 positive integers in a line: N (≤10^{5}), the total number of people to be ranked; L (≥60), the lower bound of the qualified grades -- that is, only the ones whose grades of talent and virtue are both not below this line will be ranked; and H (<100), the higher line of qualification -- that is, those with both grades not below this line are considered as the "sages", and will be ranked in non-increasing order according to their total grades. Those with talent grades below H but virtue grades not are considered as the "noblemen", and are also ranked in non-increasing order according to their total grades, but they are listed after the "sages". Those with both grades below H, but with virtue not lower than talent are considered as the "fool men". They are ranked in the same way but after the "noblemen". The rest of people whose grades both pass the L line are ranked after the "fool men".

Then N lines follow, each gives the information of a person in the format:

ID_Number Virtue_Grade Talent_Grade

where ID_Number is an 8-digit number, and both grades are integers in [0, 100]. All the numbers are separated by a space.

输出

The first line of output must give M (≤N), the total number of people that are actually ranked. Then M lines follow, each gives the information of a person in the same format as the input, according to the ranking rules. If there is a tie of the total grade, they must be ranked with respect to their virtue grades in non-increasing order. If there is still a tie, then output in increasing order of their ID's.

样例输入 

14 60 80
10000001 64 90
10000002 90 60
10000011 85 80
10000003 85 80
10000004 80 85
10000005 82 77
10000006 83 76
10000007 90 78
10000008 75 79
10000009 59 90
10000010 88 45
10000012 80 100
10000013 90 99
10000014 66 60

样例输出 

12
10000013 90 99
10000012 80 100
10000003 85 80
10000011 85 80
10000004 80 85
10000007 90 78
10000006 83 76
10000005 82 77
10000002 90 60
10000014 66 60
10000008 75 79
10000001 64 90

题意理解

输入第1行给出3个正整数,分别为:N(<=10^{5}),即考生总数;L(>=60),为录取最低分数线,即德分和才分均不低于L的考生才有资格被考虑录取;H(<100),为优先录取线——德分和才分均不低于此线的被定义为“才德全尽”,此类考生按德才总分从高到低排序;才分不到但德分到线的一类考生属于“德胜才”,也按总分排序,但排在第一类考生之后;德才分均低于H,但是德分不低于才分的考生属于“才德兼亡”但尚有“德胜才”者,按总分排序,但排在第二类考生之后;其他达到最低线L的考生也按总分排序,但排在第三类考生之后

然后每一行就是 准考证 德分 才分

那么我们直接重写cmp函数然后将每类符合条件的筛选出来即可

代码 

#include<bits/stdc++.h> 
#define INF 0x3f3f3f3f
const int  MOD =1e9+7;
using namespace std;
#define N 100010
#define ll long long 
typedef struct pe{
	int a,b,c;//b是德 c是才 
	int sum;
}pe;
pe nu[N];
bool cmp(pe a,pe b){
	if(a.sum==b.sum){
		if(a.b==b.b&&a.sum==b.sum){
			return a.a<b.a;
		}
		return a.b>b.b;
	}
	return a.sum>b.sum;
}
int main(){
    int n,l,h;
    cin>>n>>l>>h;
    int k1=0;
    for(int i=0;i<n;i++){
    	scanf("%d%d%d",&nu[i].a,&nu[i].b,&nu[i].c);
    	nu[i].sum=nu[i].b+nu[i].c;
    	if(nu[i].b>=l&&nu[i].c>=l){
    		k1++;
	    }
	
	}
	sort(nu,nu+n,cmp);
	cout<<k1<<endl;

	for(int i=0;i<n;i++){
		if(nu[i].b>=h&&nu[i].c>=h)
		   printf("%d %d %d\n",nu[i].a,nu[i].b,nu[i].c);
	}
	for(int i=0;i<n;i++){
		if(nu[i].b>=h&&nu[i].c<h&&nu[i].c>=l)
		   printf("%d %d %d\n",nu[i].a,nu[i].b,nu[i].c);
	}
	for(int i=0;i<n;i++){
		if(nu[i].b>=l&&nu[i].b<h&&nu[i].c>=l&&nu[i].c<h)
		   if(nu[i].b>=nu[i].c)
		      printf("%d %d %d\n",nu[i].a,nu[i].b,nu[i].c);
	}
	for(int i=0;i<n;i++){
		if(nu[i].b>=l&&nu[i].c>=l&&(nu[i].b<h||nu[i].c<h) )
		   if(nu[i].b<nu[i].c)
		      printf("%d %d %d\n",nu[i].a,nu[i].b,nu[i].c);
	}
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值