PAT甲级 1068 Find More Coins(30) (DP+背包路径)

题目

Eva loves to collect coins from all over the universe, including some other planets like Mars. One day she visited a universal shopping mall which could accept all kinds of coins as payments. However, there was a special requirement of the payment: for each bill, she must pay the exact amount. Since she has as many as 10^{4} coins with her, she definitely needs your help. You are supposed to tell her, for any given amount of money, whether or not she can find some coins to pay for it.

输入

Each input file contains one test case. For each case, the first line contains 2 positive numbers: N (≤10^{4}, the total number of coins) and M (≤10^{2}, the amount of money Eva has to pay). The second line contains N face values of the coins, which are all positive numbers. All the numbers in a line are separated by a space.

输出

For each test case, print in one line the face values V_{1}​≤V_{2}​≤⋯≤V_{K}​ such that V_{1}​+V_{2}+⋯+V_{K}​=M. All the numbers must be separated by a space, and there must be no extra space at the end of the line. If such a solution is not unique, output the smallest sequence. If there is no solution, output "No Solution" instead.

Note: sequence {A[1], A[2], ...} is said to be "smaller" than sequence {B[1], B[2], ...} if there exists k≥1 such that A[i]=B[i] for all i<k, and A[k] < B[k].

样例输入 

样例输入1:

8 9
5 9 8 7 2 3 4 1
样例输入2:

4 8
7 2 4 3

样例输出 

样例输出1:

1 3 5
样例输出2:

No Solution

题意理解

给你一些硬币的价值 看这些硬币能不能凑到m的价值

用了经典的背包

我们用二维记录路径 如果单单一维的话很难记录路径

如果凑不出来m的价值的话 输出No Solution

要注意的是我们最后输出的是字典序最小的那个方案 也就是多个方案的情况下

那么我们将所有硬币价值排个序 最后输出的就是字典序最小的那个方案了

我们从后往前推过来

如果我的 后一个状态等于我前一个状态的总值+这个硬币的价值

说明我就是从上一个状态加了这个硬币以后变到了现在这个状态

也就是

从后往前 i 是后面的状态 i-1是前面的状态 ans是我当前装的总价值 

f[i][ans]==f[i-1][ans-v[i]]+v[i]

只要满足那么我这个硬币就是已经拿掉了 所以我把这个硬币的价值减去

边减去价值 边记录我拿的硬币的价值是多少 最后输出

由于我们前面已经排好序了 那么我们输出的一定是最小的字典序 而且我们是从后往前的去找硬币的

代码 

#include <bits/stdc++.h>
using namespace std;
const int N=1e5+10,M=1e2+10;
int f[N][M];
int n,m;
int v[N];
int main()
{
    cin>>n>>m;
    for(int i=1;i<=n;i++){
        scanf("%d",&v[i]);
    }
    sort(v+1,v+1+n,greater<int>());
    for(int i=1;i<=n;i++){
        for(int j=0;j<=m;j++){
            f[i][j]=f[i-1][j];
            if (j>=v[i])f[i][j]=max(f[i][j],f[i-1][j-v[i]]+v[i]);
        }
    }
    if(f[n][m]!=m){
        puts("No Solution");
        return 0;
    }
    else {
        int ans=m;
        vector<int>ve;
        for(int i=n;i>=1;i--){
            if(ans>0&&f[i][ans]==f[i-1][ans-v[i]]+v[i]){
                ans-=v[i];
                ve.push_back(v[i]);
            }
        }
        for(int i=0;i<ve.size();i++){
            if(i)printf(" ");
            printf("%d",ve[i]);
        }
        puts("");
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
#include <iostream>#include <cstdlib>using namespace std;struct Coin { int weight; // 硬币的重量 bool is_fake; // 是否为假币};Coin coins[100];// 将硬币分成两等份并比较的功能,返回较轻的那一半硬币的重量总和int balance(int start, int end) { int sum = 0; for (int i = start; i <= end; i++) { sum += coins[i].weight; } return sum;}int find_fake_coin(int start, int end) { int len = end - start + 1; if (len == 2) { // 只剩下两个硬币 if (coins[start].weight < coins[end].weight) { return start; } else { return end; } } else if (len == 3) { // 只剩下三个硬币 int index = rand() % 3 + start; if (index == start) { // 取出第一枚硬币作为样本 if (coins[start + 1].weight == coins[start + 2].weight) { return start; } else if (coins[start + 1].weight < coins[start + 2].weight) { return start + 1; } else { return start + 2; } } else if (index == start + 1) { // 取出第二枚硬币作为样本 if (coins[start].weight == coins[start + 2].weight) { return start + 1; } else if (coins[start].weight < coins[start + 2].weight) { return start; } else { return start + 2; } } else { // 取出第三枚硬币作为样本 if (coins[start].weight == coins[start + 1].weight) { return start + 2; } else if (coins[start].weight < coins[start + 1].weight) { return start; } else { return start + 1; } } } else { // 将硬币分成两等份并比较 int mid = (start + end) / 2; int left_sum = balance(start, mid); int right_sum = balance(mid + 1, end); if (left_sum < right_sum) { return find_fake_coin(start, mid); } else if (left_sum > right_sum) { return find_fake_coin(mid + 1, end); } else { return -1; // 不可能出现的情况 } }}int main() { int n; cout << "请输入硬币的数量n:"; cin >> n; srand(time(NULL)); int fake_index = rand() % n; // 随机生成假币的位置 for (int i = 0; i < n; i++) { coins[i].weight = 10; // 正常硬币的重量为10g if (i == fake_index) { coins[i].weight = 8; // 假币的重量为8g coins[i].is_fake = true; } else { coins[i].is_fake = false; } } int fake = find_fake_coin(0, n - 1); cout << "假币的位置是:" << fake << endl; return 0;}求此算法的运行结果和算法时间复杂度
06-08

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值