PAT甲级 1068 Find More Coins (30分) 01背包+路径更新

**

1068 Find More Coins (30分)

**

Eva loves to collect coins from all over the universe, including some other planets like Mars. One day she visited a universal shopping mall which could accept all kinds of coins as payments. However, there was a special requirement of the payment: for each bill, she must pay the exact amount. Since she has as many as 10​4​​ coins with her, she definitely needs your help. You are supposed to tell her, for any given amount of money, whether or not she can find some coins to pay for it.
Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive numbers: N (≤10​4​​, the total number of coins) and M (≤10​2​​, the amount of money Eva has to pay). The second line contains N face values of the coins, which are all positive numbers. All the numbers in a line are separated by a space.
Output Specification:

For each test case, print in one line the face values V​1​​≤V​2​​≤⋯≤V​k​​ such that V​1​​+V​2​​+⋯+V​k​​=M. All the numbers must be separated by a space, and there must be no extra space at the end of the line. If such a solution is not unique, output the smallest sequence. If there is no solution, output “No Solution” instead.

Note: sequence {A[1], A[2], …} is said to be “smaller” than sequence {B[1], B[2], …} if there exists k≥1 such that A[i]=B[i] for all i<k, and A[k] < B[k].
Sample Input 1:

8 9
5 9 8 7 2 3 4 1

Sample Output 1:

1 3 5

Sample Input 2:

4 8
7 2 4 3

Sample Output 2:

No Solution

题意:给定n个硬币的面值,给定总共需要的面值m,能否找出其中一些硬币的面值和等于m,如果有输出其中字典序最小的,否则输出No Solution。

题解:很裸的01背包了吧,因为数据m最大为100,表示背包的空间,然后就是01背包找背包空间为m时的最大面值和,其次不断更新路径,路径可以用vector储存更新,比较方便。

AC代码

#include<bits/stdc++.h>
using namespace std;
const int N=1e4+100;
//比较字典序 
bool check(vector<int>a,vector<int>b)
{
	//注意排序比较数字 
	sort(a.begin(),a.end());
	sort(b.begin(),b.end());
	int n=min(a.size(),b.size());
	for(int i=0;i<n;i++)
	if(a[i]<b[i])return true;
	return false;
}
int dp[200],a[N];
vector<int>path[200];
int main()
{
	std::ios::sync_with_stdio(false);
	int n,m;
	cin>>n>>m;
	for(int i=1;i<=n;i++)
	cin>>a[i];
	for(int i=1;i<=m;i++)
	path[i].clear();
	memset(dp,0,sizeof(dp));
	//开始01背包 
	for(int i=1;i<=n;i++)
	{
		for(int j=m;j>=1;j--)
		{
			if((j-a[i])>=0)
			{
				int ans=dp[j-a[i]]+a[i];
				//更新路径 
				vector<int>path_new=path[j-a[i]];
				path_new.push_back(a[i]);
				if(ans>dp[j])
				{
					dp[j]=ans;
					path[j]=path_new;
				}
				else if(ans==dp[j])
				{
					if(check(path_new,path[j]))
					path[j]=path_new;
				}
			}
			
		}
	}
	if(dp[m]<m)
	{
		cout<<"No Solution\n";
		return 0;
	}
	sort(path[m].begin(),path[m].end());
	cout<<path[m][0];
	for(int i=1;i<path[m].size();i++)
	cout<<" "<<path[m][i];
	cout<<endl; 
	return 0;
}

在这里插入图片描述

评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值