POJ - 2828 Buy Tickets 线段树题解

Description

Railway tickets were difficult to buy around the Lunar New Year in China, so we must get up early and join a long queue…

The Lunar New Year was approaching, but unluckily the Little Cat still had schedules going here and there. Now, he had to travel by train to Mianyang, Sichuan Province for the winter camp selection of the national team of Olympiad in Informatics.

It was one o’clock a.m. and dark outside. Chill wind from the northwest did not scare off the people in the queue. The cold night gave the Little Cat a shiver. Why not find a problem to think about? That was none the less better than freezing to death!

People kept jumping the queue. Since it was too dark around, such moves would not be discovered even by the people adjacent to the queue-jumpers. “If every person in the queue is assigned an integral value and all the information about those who have jumped the queue and where they stand after queue-jumping is given, can I find out the final order of people in the queue?” Thought the Little Cat.

Input

There will be several test cases in the input. Each test case consists of N + 1 lines where N (1 ≤ N ≤ 200,000) is given in the first line of the test case. The next N lines contain the pairs of values Posi and Vali in the increasing order of i (1 ≤ i ≤ N). For each i, the ranges and meanings of Posi and Vali are as follows:

Posi ∈ [0, i − 1] — The i-th person came to the queue and stood right behind the Posi-th person in the queue. The booking office was considered the 0th person and the person at the front of the queue was considered the first person in the queue.
Vali ∈ [0, 32767] — The i-th person was assigned the value Vali.
There no blank lines between test cases. Proceed to the end of input.

Output

For each test cases, output a single line of space-separated integers which are the values of people in the order they stand in the queue.

Sample Input

4
0 77
1 51
1 33
2 69
4
0 20523
1 19243
1 3890
0 31492

Sample Output

77 33 69 51
31492 20523 3890 19243

Hint

The figure below shows how the Little Cat found out the final order of people in the queue described in the first test case of the sample input.
这里写图片描述


显然这道题可以用线段树写,是一道思维题,需要转个弯,因为这道题需要从后往前插入,原因是后面的不会影响前面的,但是前面的会影响后面的,举个例子,我最后一个插入的位置是五,那么五这个位置就铁定是我最后插入的这个值了,而前面插入的会被影响,所以我们从后往前插入,用线段树维护一个区间的空位,显然如果左区间空位足够就往左插入,反之向右插入,然后需要注意的是,每一个点插入之后,就一定不会动了(一定一定),所以只需要从左往右数空位,然后放数就可以啦


#include<cstdio>  
using namespace std;
int sum[200000*4],final[200000],pos[200000],val[200000];  
void pushup(int rt){sum[rt]=sum[rt<<1]+sum[rt<<1|1];}
void build(int l,int r,int rt){
    if(l==r){sum[rt]=1;return;}
    int mid=(l+r)>>1;
    build(l,mid,rt<<1);
    build(mid+1,r,rt<<1|1);
    pushup(rt);
} 
void query(int loc,int person,int l,int r,int rt){
    if(l==r){final[l]=person;sum[rt]=0;return;}
    int mid=(l+r)>>1;
    if(sum[rt<<1]>=loc) query(loc,person,l,mid,rt<<1);
    else                query(loc-sum[rt<<1],person,mid+1,r,rt<<1|1);
    pushup(rt);
}
int main(){
    int n;
    while(scanf("%d",&n)!=-1){
        build(1,n,1);
        for(register int i=1;i<=n;i++) scanf("%d%d",&pos[i],&val[i]);
        for(register int i=n;i>=1;i--) query(pos[i]+1,val[i],1,n,1);
        for(register int i=1;i<n;i++)  printf("%d ",final[i]);
        printf("%d\n",final[n]); 
    }
    return 0;
} 

这里写图片描述

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值