线段树单点更新——POJ 2828

对应POJ题目:点击打开链接


Time Limit: 4000MS Memory Limit: 65536KB 64bit IO Format: %I64d & %I64u

[]   [Go Back]   [Status]  

Description

Railway tickets were difficult to buy around the Lunar New Year in China, so we must get up early and join a long queue…

The Lunar New Year was approaching, but unluckily the Little Cat still had schedules going here and there. Now, he had to travel by train to Mianyang, Sichuan Province for the winter camp selection of the national team of Olympiad in Informatics.

It was one o’clock a.m. and dark outside. Chill wind from the northwest did not scare off the people in the queue. The cold night gave the Little Cat a shiver. Why not find a problem to think about? That was none the less better than freezing to death!

People kept jumping the queue. Since it was too dark around, such moves would not be discovered even by the people adjacent to the queue-jumpers. “If every person in the queue is assigned an integral value and all the information about those who have jumped the queue and where they stand after queue-jumping is given, can I find out the final order of people in the queue?” Thought the Little Cat.

Input

There will be several test cases in the input. Each test case consists of N + 1 lines where N (1 ≤ N ≤ 200,000) is given in the first line of the test case. The next N lines contain the pairs of values Posi and Vali in the increasing order of i (1 ≤ i ≤ N). For each i, the ranges and meanings of Posi and Vali are as follows:

  • Posi ∈ [0, i − 1] — The i-th person came to the queue and stood right behind the Posi-th person in the queue. The booking office was considered the 0th person and the person at the front of the queue was considered the first person in the queue.
  • Vali ∈ [0, 32767] — The i-th person was assigned the value Vali.

There no blank lines between test cases. Proceed to the end of input.

Output

For each test cases, output a single line of space-separated integers which are the values of people in the order they stand in the queue.

Sample Input

4
0 77
1 51
1 33
2 69
4
0 20523
1 19243
1 3890
0 31492

Sample Output

77 33 69 51
31492 20523 3890 19243

Hint

The figure below shows how the Little Cat found out the final order of people in the queue described in the first test case of the sample input.


题意:

就是n个人排队,每输入一组(pos, val)表示这个人要插入到pos这个位置,原来在pos位置及其后面的都要向后移动一位,求最终的队伍序列


思路:

脑子转不过来,没办法╮(╯_╰)╭,看别人的思路;就是要倒过来看输入,即先看最后一组输入,(2,69),这里我每个pos都右移一位,当是(3,69),即这个数要插在第3个位置,它前面肯定要空2个位置(因为肯定要插2个数,所以区间[1,3]肯定要有3个空位),然后是(1+1,33),这个数要插在第2个位置,它前面肯定要空1个位置(区间[1,2]要有2个空位),再然后是(1+1,51),重点!因为这个数也要插在第2个位置,但是这个位置已经有数;它只能往右边走,走到使区间[1,某pos]有2个空位...

线段树结点维护的是该区间有多少个空位置,遍历就是往左走,走不了就往右走

我的理解大概就是这样


#include<cstdio>
#include<cstdlib>
#include<cmath>
#include<map>
#include<queue>
#include<stack>
#include<vector>
#include<algorithm>
#include<cstring>
#include<string>
#include<iostream>
#define ms(x,y) memset(x,y,sizeof(x))
const int MAXN=200000+10;
const int INF=1<<30;
using namespace std;
int a[MAXN];
int b[MAXN];
int res[MAXN*4];
int ans[MAXN];

void buildtree( int rt, int left, int right )
{
	if( left == right ){
		res[rt] = 1;
		return;
	}
	int mid = ( left + right )>>1;
	buildtree( rt<<1, left, mid );
	buildtree( rt<<1|1, mid+1, right );
	res[rt] = res[rt<<1] + res[rt<<1|1];
}

void updata( int rt, int left, int right, int pos, int val )
{
	if( left == right ){
		ans[left] = val;
		res[rt] = 0;
		return;
	}
	int mid = ( left + right )>>1;
	if(res[rt] >= pos ){//如果这个结点空位置都不满足,那子节点也不用看了
		if( res[rt<<1] >= pos ) updata( rt<<1, left, mid, pos, val );//左边能走
		else updata( rt<<1|1, mid+1, right, pos-res[rt<<1], val );//左边不能走,走右边
		res[rt] = res[rt<<1] + res[rt<<1|1];//更新数据
	}
}

int main()
{
#if 0
	freopen("in.txt","r",stdin);
#endif
	int n;
	while(scanf("%d", &n)==1)
	{
		buildtree(1,1,n);
		for(int i=0; i<n; i++) scanf("%d%d", &b[i],&a[i]);
		for(int i=n-1; i>=0; i--)
			updata(1,1,n,b[i]+1,a[i]);	
		printf("%d", ans[1]);
		for(int i=2; i<=n; i++)
			printf(" %d", ans[i]);
		printf("\n");
	}
	return 0;
}









评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值