HDU-1020-Encoding,题意不清,其实很水~~

Encoding

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)


http://acm.hdu.edu.cn/showproblem.php?pid=1020

Problem Description
Given a string containing only 'A' - 'Z', we could encode it using the following method: 

1. Each sub-string containing k same characters should be encoded to "kX" where "X" is the only character in this sub-string.

2. If the length of the sub-string is 1, '1' should be ignored.
 

Input
The first line contains an integer N (1 <= N <= 100) which indicates the number of test cases. The next N lines contain N strings. Each string consists of only 'A' - 'Z' and the length is less than 10000.
 

Output
For each test case, output the encoded string in a line.
 

Sample Input
  
  
2 ABC ABBCCC
 

Sample Output
  
  
ABC A2B3C

      这个题真心不难,只不过题意没标明相同字母连续的时候输出个数,还是直接输出字符串中所有相同的个数。

     如果是先输出整个字符串中相同字母的个数再输出字母,这样要复杂一点,当然了,该字母只有唯一一个则直接输出。如果是先输出连续相同的字母的个数再输出字母这样其实更简单。

    看第一种情况代码(WA)

#include<bits/stdc++.h>
using namespace std;
const int N=10000+10;
char a[N];
int b[100];
int main()
{
    int t,x,i;
    scanf("%d",&t);
    getchar();
    while(t--)
    {
        scanf("%s",a);
        x=strlen(a);
        memset(b,0,sizeof(b));
        for(i=0;i<x;i++)
            b[a[i]-'0']++;//将此类字母个数统计出来;
            for(i=0;i<x;i++)
            {
                if(b[a[i]-'0']!=1&&b[a[i]-'0']!=0)
                {
                    printf("%d",b[a[i]-'0']);
                    printf("%c",a[i]);
                    b[a[i]-'0']=0;
                }
                if(b[a[i]-'0']!=0)//如果已经输出过就不用再输出此类字母了;
                printf("%c",a[i]);
            }
            printf("\n");
    }
    return 0;
}

来看第二种代码(AC):
#include<bits/stdc++.h>
using namespace std;
const int N=10000+10;
char a[N];
int main()
{
    int t,x,i,k;
    scanf("%d",&t);
    getchar();
    while(t--)
    {
        scanf("%s",a);
        x=strlen(a);
        k=1;
        for(i=1; i<=x; i++)
        {
            if(a[i]==a[i-1])
                k++;//统计出连续相同的字母个数直接输出;
            else
            {
                if(k!=1)//该种字母个数为一就不用将个数输出;
                    printf("%d",k);
                printf("%c",a[i-1]);
                k=1;
            }
        }
        printf("\n");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值