HNU Knockout Racing

题目链接http://acm.hnu.cn/online/?action=problem&type=show&id=13342&courseid=0
Problem description

The races became more popular than ever at Pandora planet. But these races are quite unusual. There are n cars participating in a race on the long straight track. Each car moves with a speed of 1 meter per second. Track has coordinates in meters.

The car number i moves between two points on the track with coordinates ai and bi starting at the second 0 in the point ai. The car moves from ai to bi, then from bi to ai, then from ai to bi again, and so on. Handsome Mike wants to knock some cars out of the race using dynamite. Thus he has m questions. The question number j is: what is the number of cars in the coordinates between xj and yj inclusive after tj seconds from the start? Your task is to answer Mike’s questions.

Input

The first line of the input file contains two integers n and m (1 ≤ n,m ≤ 1000) — the number of cars in the race and the number of questions. Each of the following n lines contains a description of the car: two integers ai and bi(0 ≤ ai,bi≤ 10^9, ai ≠ bi) — the coordinates of the two points between which the car i moves. Each of the following m lines contains a description of the question: three integers xj, yj, and tj (0 ≤ xj≤ yj≤ 10^9, 0 ≤ tj≤ 10^9) — the coordinate range and the time for the question j.

Output

Write m lines to the output file. Each line must contain one integer — the answer to the corresponding question in order they are given in the input file.

Sample Input
5 5
0 1
0 2
2 3
3 5
4 5
0 5 0
0 1 2
0 2 1
2 5 2
2 5 3

Sample Output
5
1
2
4
3

Problem Source
NEERC 2014

水题= =直接上代码

#include<stdio.h>
#include<string.h>
#include<iostream>
#include<algorithm>
#define maxn 1000+100 
using namespace std;
struct node
{
    int x,y;
}a[maxn];
int main()
{
    int n,m;
    scanf("%d %d",&n,&m);
    for(int i=0;i<n;i++)
    {
        scanf("%d %d",&a[i].x,&a[i].y);
    }
    while(m--)
    {
        int xx,yy,t;
        scanf("%d %d %d",&xx,&yy,&t);
        int count=0;
        for(int i=0;i<n;i++)
        {
            int tx=0;
            if(t<(a[i].y-a[i].x))
            {
                tx=a[i].x+t;
            } 
            else
            {
                 int  u=t%(a[i].y-a[i].x);
                 int  v=t/(a[i].y-a[i].x); 
                 if(v&1) 
                 tx=a[i].y-u; 
                 else
                 tx=a[i].x+u; 
              } 
              if(tx>=xx&&tx<=yy)
              {
                  count++;
              } 
        }
        printf("%d\n",count);
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值