L - Dollars 完全背包

L - Dollars   UVA - 147


Dollars

New Zealand currency consists of $100, $50, $20, $10, and $5 notes and $2, $1, 50c, 20c, 10c and 5c coins. Write a program that will determine, for any given amount, in how many ways that amount may be made up. Changing the order of listing does not increase the count. Thus 20c may be made up in 4 ways: 1 tex2html_wrap_inline25 20c, 2 tex2html_wrap_inline25 10c, 10c+2 tex2html_wrap_inline25 5c, and 4 tex2html_wrap_inline25 5c.

Input

Input will consist of a series of real numbers no greater than $300.00 each on a separate line. Each amount will be valid, that is will be a multiple of 5c. The file will be terminated by a line containing zero (0.00).

Output

Output will consist of a line for each of the amounts in the input, each line consisting of the amount of money (with two decimal places and right justified in a field of width 6), followed by the number of ways in which that amount may be made up, right justified in a field of width 17.

Sample input

0.20
2.00
0.00

Sample output

  0.20                4
  2.00              293

题意:一共11种硬币,然后给你一个硬币数,问有多少种组成方法。且输出有空格要求。

分析:各种硬币数无限,所以是完全背包。先把输入的m转换为整数n,n=( int ) (m*100.0+0.5),注意double转换为int时要四舍五入。dp[i]表示组成i分的硬币有多少种方法。

代码:

#include<iostream>
#include<cstdio>
#include<string.h>
using namespace std;
typedef long long ll;
const int N=30005;
int n,w[11]={5,10,20,50,100,200,500,1000,2000,5000,10000};
ll dp[N];
int main()
{
	double m;
	dp[0]=1;
	for(int i=0;i<11;i++)
	{
		for(int j=w[i];j<N;j++)
			dp[j]+=dp[j-w[i]];
	}
	while(~scanf("%lf",&m))
	{
		if(m==0.00)
			break;
		n=(int)(m*100.0+0.5);
		printf("%6.2lf%17lld\n",m,dp[n]);
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值