B - Dollars (完全背包)

B - Dollars
Time Limit:0MS     Memory Limit:0KB     64bit IO Format:%lld & %llu

Description

New Zealand currency consists of $100, $50, $20, $10, and $5 notes and $2, $1, 50c, 20c, 10c and 5c coins. Write a program that will determine, for any given amount, in how many ways that amount may be made up. Changing the order of listing does not increase the count. Thus 20c may be made up in 4 ways: 1 tex2html_wrap_inline25 20c, 2 tex2html_wrap_inline25 10c, 10c+2 tex2html_wrap_inline25 5c, and 4 tex2html_wrap_inline25 5c.

Input

Input will consist of a series of real numbers no greater than $50.00 each on a separate line. Each amount will be valid, that is will be a multiple of 5c. The file will be terminated by a line containing zero (0.00).

Output

Output will consist of a line for each of the amounts in the input, each line consisting of the amount of money (with two decimal places and right justified in a field of width 5), followed by the number of ways in which that amount may be made up, right justified in a field of width 12.

Sample input

0.20
  2.00
0.00

Sample output

 0.20           4
 2.00         293

 

这题用以前习惯的写法我WA了 很多次啊,最后换了一种方法才学对,我把AC和WA的程序进行了对比,发现都所有的测试数据都是一样的,但是就是过不了, 这我就想不通的。。。。

不过最后在月神的帮助下,我终于再次涨姿势了

原来double 强制转换为int  会出错啊

好吧。。。  我记住了

贴出我WA的代码:

#include<stdio.h>
#include<math.h>
#include<string.h>
#include<algorithm>
#include<limits.h>
using namespace std;
int main()
{
	int a[]={0,5,10,20,50,100,200,500,1000,2000,5000,10000};
	int f[6666];
	//memset(f,0,sizeof(f));
	for(int i=1; i<= 6000; i++)
		f[i]= 0;
	f[0]= 1;
	for(int i=1; i<= 11; i++)
		for(int j= 6000; j>= 1; j--)
			for(int k =1; k<= j/a[i]; k++)
				if(j>=k*a[i]&&f[j-k*a[i]]>0)
					f[j]+= f[j-k*a[i]]; 
	double n;
	while(scanf("%lf",&n)!=EOF&&n)
	{
		double m= n;
		m*= 100;
		int t;
		t= m;//  此处强制转换会错,  月神说double型的数储存时会有精度误差 
		printf("%5.2lf%12d\n",n,f[t]);
	}
return 0;
}


然后月神帮了改了一下代码就A掉了

AC代码:

#include<stdio.h>
#include<math.h>
#include<string.h>
#include<algorithm>
#include<limits.h>
using namespace std;
int main()
{
	int a[]={0,5,10,20,50,100,200,500,1000,2000,5000,10000};
	int f[6666];
	//memset(f,0,sizeof(f));
	for(int i=1; i<= 6000; i++)
		f[i]= 0;
	f[0]= 1;
	for(int i=1; i<= 11; i++)
		for(int j= 6000; j>= 1; j--)
			for(int k =1; k<= j/a[i]; k++)
				if(j>=k*a[i]&&f[j-k*a[i]]>0)
					f[j]+= f[j-k*a[i]]; 
	int  x,y;
	while(scanf("%d.%d",&x,&y)!=EOF&&x+y)
	{
		//double m= n;
		//m*= 100;
		int t;
		t= x* 100+ y;//  月神修改部分 
		printf("%2d.%02d%12d\n",x,y,f[t]);
	}
return 0;
}


 

 

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值