Connections in Galaxy War ZOJ - 3261 并查集+思维

题目

In order to strengthen the defense ability, many stars in galaxy allied together and built many bidirectional tunnels to exchange messages. However, when the Galaxy War began, some tunnels were destroyed by the monsters from another dimension. Then many problems were raised when some of the stars wanted to seek help from the others.

In the galaxy, the stars are numbered from 0 to N-1 and their power was marked by a non-negative integer pi. When the star A wanted to seek help, it would send the message to the star with the largest power which was connected with star A directly or indirectly. In addition, this star should be more powerful than the star A. If there were more than one star which had the same largest power, then the one with the smallest serial number was chosen. And therefore, sometimes star A couldn't find such star for help.

Given the information of the war and the queries about some particular stars, for each query, please find out whether this star could seek another star for help and which star should be chosen.

Input

There are no more than 20 cases. Process to the end of file.

For each cases, the first line contains an integer N (1 <= N <= 10000), which is the number of stars. The second line contains N integers p0, p1, ... , pn-1 (0 <= pi <= 1000000000), representing the power of the i-th star. Then the third line is a single integer M (0 <= M <= 20000), that is the number of tunnels built before the war. Then M lines follows. Each line has two integers a, b (0 <= a, b <= N - 1, a != b), which means star a and star b has a connection tunnel. It's guaranteed that each connection will only be described once.

In the (M + 2)-th line is an integer Q (0 <= Q <= 50000) which is the number of the information and queries. In the following Q lines, each line will be written in one of next two formats.

"destroy a b" - the connection between star a and star b was destroyed by the monsters. It's guaranteed that the connection between star a and star b was available before the monsters' attack.

"query a" - star a wanted to know which star it should turn to for help

There is a blank line between consecutive cases.

Output

For each query in the input, if there is no star that star a can turn to for help, then output "-1"; otherwise, output the serial number of the chosen star.

Print a blank line between consecutive cases.

Sample Input

2
10 20
1
0 1
5
query 0
query 1
destroy 0 1
query 0
query 1

Sample Output

1
-1
-1
-1

题意

多组输入,第一行一个n,表示有0到n-1这n个点,第二行给出每个点的权值,第三行给出一个m,表示已经存在m条边,接下来m行,每行两个数,表示这两个数之间有边链接,接下来一行给出Q,表示Q此操作,query表示询问某个点能到达的点中,权值最大的,在保证权值最大的基础上取下标最小的,destroy表示破坏某两个点之间的边。

分析

这个题一看,并查集,但右涉及到删除边的操作,想了一会不会做,后来看了别人的博客才知道,这个题要倒序做。正序破坏不就是倒序建立嘛。首先,先将那m条边记录下来,但是不进行unionn操作,然后,在Q次操作中,记录下被破坏的边。被破坏的边记录完以后,再进行unionn操作。m条边中,被破坏的先不建立,其他的建立。然后,倒序遍历Q次操作,如果遇到记录的被破坏的边,那么建立,如果遇到查询,就先将结果存在ans数组中,最后倒着输出ans数组的值。

代码

#include<iostream>
#include<cstdio>
#include<string.h>
#include<map>
using namespace std;
const int N=1e4+5;
int n,m,Q;
struct node{
	int a,b,flag;
}t[N<<1],q[50005];//t[]:记录已经存在的边,q[]:记录破坏的边  
int pre[N],num[N],ans[N<<3];//根节点、权值、结果  
int find(int x)
{
	int r=x;
	while(r!=pre[r])
		r=pre[r];
	int tmp,a=x;
	while(a!=r)
	{
		tmp=pre[a];
		pre[a]=r;
		a=tmp;
	}
	return r;
}
void unionn(int x,int y)
{
	int r1=find(x);
	int r2=find(y);
	if(r1!=r2)
	{
		//以大的为根,相等时以下标小的为根  
		if(num[r1]>num[r2]||num[r1]==num[r2]&&r1<r2)
			pre[r2]=r1;
		else
			pre[r1]=r2;
	}
}
int main()
{
	char c[15];
	bool ok=0;
	while(~scanf("%d",&n))
	{
		if(ok)//格式 
			printf("\n");
		ok=1;
		map<int,bool> M;
		for(int i=0;i<n;i++)
		{
			pre[i]=i;
			scanf("%d",&num[i]);
		}
		scanf("%d",&m);
		for(int i=0;i<m;i++)
		{
			scanf("%d%d",&t[i].a,&t[i].b);//记录已经存在的m条边  
			if(t[i].a>t[i].b)
				swap(t[i].a,t[i].b);
		}
		scanf("%d",&Q);
		for(int i=0;i<Q;i++)
		{
			scanf("%s",c);
			if(c[0]=='d')
			{
				scanf("%d%d",&q[i].a,&q[i].b);
				if(q[i].a>q[i].b)
					swap(q[i].a,q[i].b);
				q[i].flag=1;	//记录破坏的边  
				M[q[i].a*N+q[i].b]=1;
			}
			else
			{
				scanf("%d",&q[i]);
				q[i].flag=0;
			}
		}
		for(int i=0;i<m;i++)
		{
			if(M[t[i].a*N+t[i].b]==0)//先建立没有被破坏的边  
				unionn(t[i].a,t[i].b);
		}
		int cnt=0;
		for(int i=Q-1;i>=0;i--)
		{
			if(q[i].flag)
				unionn(q[i].a,q[i].b);//重建  
			else
			{
				int rt=find(q[i].a);
				if(num[rt]>num[q[i].a])
					ans[cnt++]=rt;
				else
					ans[cnt++]=-1;
			}
		}
		for(int i=cnt-1;i>=0;i--)//倒序存的,所以倒着输出  
			printf("%d\n",ans[i]);
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值