ZOJ - 3261 Connections in Galaxy War

Connections in Galaxy War


Time Limit: 3 Seconds      Memory Limit: 32768 KB


In order to strengthen the defense ability, many stars in galaxy allied together and built many bidirectional tunnels to exchange messages. However, when the Galaxy War began, some tunnels were destroyed by the monsters from another dimension. Then many problems were raised when some of the stars wanted to seek help from the others.

In the galaxy, the stars are numbered from 0 to N-1 and their power was marked by a non-negative integer pi. When the star A wanted to seek help, it would send the message to the star with the largest power which was connected with star A directly or indirectly. In addition, this star should be more powerful than the star A. If there were more than one star which had the same largest power, then the one with the smallest serial number was chosen. And therefore, sometimes star A couldn't find such star for help.

Given the information of the war and the queries about some particular stars, for each query, please find out whether this star could seek another star for help and which star should be chosen.

Input

There are no more than 20 cases. Process to the end of file.

For each cases, the first line contains an integer N (1 <= N <= 10000), which is the number of stars. The second line contains N integers p0, p1, ... , pn-1 (0 <= pi <= 1000000000), representing the power of the i-th star. Then the third line is a single integer M (0 <= M <= 20000), that is the number of tunnels built before the war. Then M lines follows. Each line has two integers a, b (0 <= a, b <= N - 1, a != b), which means star a and star b has a connection tunnel. It's guaranteed that each connection will only be described once.

In the (M + 2)-th line is an integer Q (0 <= Q <= 50000) which is the number of the information and queries. In the following Q lines, each line will be written in one of next two formats.

"destroy a b" - the connection between star a and star b was destroyed by the monsters. It's guaranteed that the connection between star a and star b was available before the monsters' attack.

"query a" - star a wanted to know which star it should turn to for help

There is a blank line between consecutive cases.

Output

For each query in the input, if there is no star that star a can turn to for help, then output "-1"; otherwise, output the serial number of the chosen star.

Print a blank line between consecutive cases.

Sample Input

2
10 20
1
0 1
5
query 0
query 1
destroy 0 1
query 0
query 1

Sample Output

1
-1
-1
-1

       这道题假设没有毁坏(destroy)这个操作的话,大家相信就很容易想到用并查集来做来做吧~~,利用并查集的时候,我们可以进行操作的有查询和添加这两部操作,而是这道题却有删除这部操作,我们该怎么办呢;

      这个时候,我们逆向操作一下,把所有的你输入都保存下来,把直到最后都没有毁坏的路径找出来进行合并 ,然后从何往前进行操作,遇到查询就是查询,遇到毁坏就是加边~~;

       对于怎么判定这个边是否到最后都还健在。。。;我们可以用map来进行一对一的判定;

#include<iostream>
#include<cstdio>
#include<vector>
#include<utility>
#include<map>
#include<string>
#include<stack>
using namespace std;
int power[10005];
struct fuck
{
	char q[20];
	int a, b;
}que[50005];
pair<int, int>ed[50005];
int fa[10005];
int Hash = 10002;
map<int, bool>link;
int find(int a)
{
	//cout << a << endl;
	if (fa[a] != a)
	{
		fa[a] = find(fa[a]);
	}
	return fa[a];
}
void unin(int a, int b)
{
//	cout <<a<<b << endl;
	int aa = find(a);
	int bb = find(b);
//	cout << "s" << endl;
	if (power[aa] > power[bb])
	{
		fa[bb] = aa;
	}
	else if (power[aa] == power[bb] && aa > bb)
	{
		fa[aa] = bb;
	}
	else if (power[aa] == power[bb] && aa < bb)
	{
		fa[bb] = aa;
	}
	else
	{
		fa[aa] = bb;
	}
}
int main()
{
	int n;
	int spot = 1;
	while (~scanf("%d", &n))
	{
		for (int s = 0; s < 10005; s++)
		{
			fa[s] = s;
		}
		for (int s = 0; s < n; s++)
		{
			scanf("%d", &power[s]);
		}
		int m;
		scanf("%d", &m);
		for (int s = 0; s < m; s++)
		{
			int a, b;
			scanf("%d%d", &a, &b);
			if (a < b)
			{
				swap(a, b);
			}
			ed[s] = make_pair(a, b);
		}
		link.clear();
		int qus;
		scanf("%d", &qus);
		for (int s = 0; s < qus; s++)
		{
			scanf("%s", &que[s].q);
			if (que[s].q[0] == 'd')
			{
				int a, b;
				scanf("%d%d", &a, &b);
				if (a < b)
				{
					swap(a, b);
				}
				que[s].a = a;
				que[s].b = b;
				link[a*Hash + b] = 1;
			}
			else
			{
				scanf("%d", &que[s].a);
			}
		}
		for (int s = 0; s < m; s++)
		{
			if (!link[ed[s].first*Hash + ed[s].second])
			{
				unin(ed[s].first, ed[s].second);
			}
		}
		stack<int>ans;
		for (int s = qus - 1; s >= 0; s--)
		{
		//	cout << que[s].q << endl;
			if (que[s].q[0] == 'd')
			{
				unin(que[s].a, que[s].b);
			}
			else
			{
		//		cout << que[s].a << endl;
				if (power[find(que[s].a)] <= power[que[s].a])
				{
					ans.push(-1);
				}
				else
				{
					ans.push(find(que[s].a));
				}
			}
		}
		if (!spot)
		{
			printf("\n");
		}
		else
		{
			spot = 0;
		}
		while (!ans.empty())
		{
			printf("%d\n", ans.top());
			ans.pop();
		}
	}
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值