题目
A Bank plans to install a machine for cash withdrawal. The machine is able to deliver appropriate @ bills for a requested cash amount. The machine uses exactly N distinct bill denominations, say Dk, k=1,N, and for each denomination Dk the machine has a supply of nk bills. For example,
N=3, n1=10, D1=100, n2=4, D2=50, n3=5, D3=10
means the machine has a supply of 10 bills of @100 each, 4 bills of @50 each, and 5 bills of @10 each.
Call cash the requested amount of cash the machine should deliver and write a program that computes the maximum amount of cash less than or equal to cash that can be effectively delivered according to the available bill supply of the machine.
Notes:
@ is the symbol of the currency delivered by the machine. For instance, @ may stand for dollar, euro, pound etc.
Input
The program input is from standard input. Each data set in the input stands for a particular transaction and has the format:
cash N n1 D1 n2 D2 ... nN DN
where 0 <= cash <= 100000 is the amount of cash requested, 0 <=N <= 10 is the number of bill denominations and 0 <= nk <= 1000 is the number of available bills for the Dk denomination, 1 <= Dk <= 1000, k=1,N. White spaces can occur freely between the numbers in the input. The input data are correct.
Output
For each set of data the program prints the result to the standard output on a separate line as shown in the examples below.
Sample Input
735 3 4 125 6 5 3 350 633 4 500 30 6 100 1 5 0 1 735 0 0 3 10 100 10 50 10 10
Sample Output
735 630 0 0
题意
大体意思就是说,要取cash数量的钱,银行里面有n中货币,每种货币都有对应的面值与数量,问能凑出来的最接近cash的金额是多少。输入:cash,n,num1,val1,num2,val2。。。。
分析
一开始就三层循环暴力,wa了,后来知道,这个要用到二进制优化。在输入时,先将每种面值的钱分组,然后就转化成了01背包。
代码
#include<iostream>
#include<cstdio>
#include<string.h>
using namespace std;
const int N=1e5+5;
int a[N],dp[N];
int main()
{
int cash,n;
while(~scanf("%d%d",&cash,&n))
{
int num,val,cnt=0;
for(int i=0;i<n;i++)
{
scanf("%d%d",&num,&val);
for(int j=1;j<num;j<<=1)//二进制优化
{
a[cnt++]=j*val;
num-=j;
}
if(num>0)
a[cnt++]=num*val;
}
if(cash==0||n==0)
{
printf("0\n");
continue;
}
memset(dp,0,sizeof(dp));
for(int i=0;i<cnt;i++)//转换成了01背包
{
for(int j=cash;j>=a[i];j--)
dp[j]=max(dp[j],dp[j-a[i]]+a[i]);
}
printf("%d\n",dp[cash]);
}
return 0;
}