poj 1276 Cash Machine(多重背包)

本文探讨了多重背包问题的解决方法,通过两种优化策略提高了算法效率。首先,将问题转化为01背包问题,实现时间复杂度的降低;其次,利用多重背包的特性,采用动态规划进一步优化求解过程。通过实例分析,展示了算法在不同输入情况下的应用效果。
摘要由CSDN通过智能技术生成
 
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 19122 Accepted: 6659

Description

A Bank plans to install a machine for cash withdrawal. The machine is able to deliver appropriate @ bills for a requested cash amount. The machine uses exactly N distinct bill denominations, say Dk, k=1,N, and for each denomination Dk the machine has a supply of nk bills. For example,

N=3, n1=10, D1=100, n2=4, D2=50, n3=5, D3=10

means the machine has a supply of 10 bills of @100 each, 4 bills of @50 each, and 5 bills of @10 each.

Call cash the requested amount of cash the machine should deliver and write a program that computes the maximum amount of cash less than or equal to cash that can be effectively delivered according to the available bill supply of the machine.

Notes:
@ is the symbol of the currency delivered by the machine. For instance, @ may stand for dollar, euro, pound etc.

Input

The program input is from standard input. Each data set in the input stands for a particular transaction and has the format:

cash N n1 D1 n2 D2 ... nN DN

where 0 <= cash <= 100000 is the amount of cash requested, 0 <=N <= 10 is the number of bill denominations and 0 <= nk <= 1000 is the number of available bills for the Dk denomination, 1 <= Dk <= 1000, k=1,N. White spaces can occur freely between the numbers in the input. The input data are correct.

Output

For each set of data the program prints the result to the standard output on a separate line as shown in the examples below.

Sample Input

735 3  4 125  6 5  3 350
633 4  500 30  6 100  1 5  0 1
735 0
0 3  10 100  10 50  10 10

Sample Output

735
630
0
0

Hint

The first data set designates a transaction where the amount of cash requested is @735. The machine contains 3 bill denominations: 4 bills of @125, 6 bills of @5, and 3 bills of @350. The machine can deliver the exact amount of requested cash.

In the second case the bill supply of the machine does not fit the exact amount of cash requested. The maximum cash that can be delivered is @630. Notice that there can be several possibilities to combine the bills in the machine for matching the delivered cash.

In the third case the machine is empty and no cash is delivered. In the fourth case the amount of cash requested is @0 and, therefore, the machine delivers no cash.

Source

[Submit] [Go Back] [Status] [Discuss]

 

Home Page Go Back To top

 

 

思路1:将多重背包转换为01背包问题

#include<cstdio>
#include<algorithm>
#include<cstring>
#define N 100005
using namespace std;
int w[N],cost[N],num[N];
int money,m;
void DP()
{
  int i,j,k;
  for(k=0;k<=money;k++)
  for(i=0;i<m;i++)
  {
    for(j=1;j<=num[i];j++)
    {
      if(k-cost[i]>=0)
      w[k]=max(w[k],w[k-cost[i]]+cost[i]);
    }
  }
}
int main()
{
  while(scanf("%d%d",&money,&m)!=EOF)
  {
    for(int i=0;i<m;i++)
    scanf("%d%d",&num[i],&cost[i]);
    memset(w,0,sizeof(w));
    DP();
    printf("%d\n",w[money]);
  }
}


超时TLE了。

思路二:利用多重背包特性

#include<cstdio>
#include<algorithm>
#include<cstring>
#define N 100005
using namespace std;
int w[N],cost[N],num[N],dpnum[N];
int money,m;
void DP()
{
  int i,j,k;
  for(i=0;i<m;i++)
  {
    memset(dpnum,0,sizeof(dpnum));
    for(j=cost[i];j<=money;j++)
    {
      if(w[j]<w[j-cost[i]]+cost[i]&&dpnum[j-cost[i]]<num[i])
      {
        w[j]=w[j-cost[i]]+cost[i];
        dpnum[j]=dpnum[j-cost[i]]+1;
      }
    }
  }
}
int main()
{
  while(scanf("%d%d",&money,&m)!=EOF)
  {
    for(int i=0;i<m;i++)
    scanf("%d%d",&num[i],&cost[i]);
    memset(w,0,sizeof(w));
    DP();
    printf("%d\n",w[money]);
  }
}



 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值